[K12OSN] Sound, trying again, please help..

Jesse McDonnell jessemcdonnell at comcast.net
Thu Feb 24 11:27:12 UTC 2005

On Thu, 24 Feb 2005 07:54:55 +0000
"George Bredberg" <jojebo68 at hotmail.com> wrote:

> Hi, have problems with terminals telling me this;
> "Cannot open the audio device. Another application may be using it."


Have you checked permissions on /dev/dsp and /dev/mixer? This error message is often the result of  incorrect permissions.  If the user starting the application doesn't have read-write access to these devices you will get the error message you described. 

 ls -al  /dev/dsp /dev/mixer will show you the permission settings on /dev/dsp and /dev/mixer.   As root, chmod a+rw /dev/dsp /dev/mixer.  Be aware that this gives all users read-write access and may have security implications if you are on an exposed network.  

A more secure solution would be to change the group owner of these devices to audio and add any users needing to use audio applications to this group.

Re your earlier posting on Realplayer, someone please correct this if it's wrong, but last time I checked (six months ago) Realplayer 10 didn't support esd. If you want to play realaudio on your clients, you'll have to use an earlier version of Realplayer. You could also run Realplayer 10 as a local application but I suspect setting this up would be a lot more challenging.

Jesse McDonnell
> Have tried this;
> echo $DISPLAY  	ws008.ltsp:0
> echo $UID 	506
> echo $ESPEAKER 	ws008.ltsp:16001
> echo $LD_PRELOAD 	/usr/lib/libesd.so.0 /usr/lib/libesddsp.so.0
> Then to "telnet ws008.ltsp 16001"
> It gives an escape character as described in 
> http://k12ltsp.org/faq.html#debug-sound
> Now, everything seems to work but still I get the above "Cannot open device" 
> How come??
> I Installed k12ltsp 4.2 and did the upgrades via yum. I have it on two 
> servers, same problem with both. Using gnome as desktop.
> In lts.conf I specified like this;
> In the default settings;
>        SOUND              = Y
>        VOLUME             = 75
>        SOUND_DAEMON     = "esd"
> In the terminal settings;
> MODULE_01       = "sb io=0x220 irq=5 dma=1"
> Even tried this;
>         SMODULE_01         = soundcore
>         SMODULE_02           = uart401
>         SMODULE_03           = "sb io=0x220 irq=5 dma=1"
> Also tried the nasd demon, but still, the same..
> A clue someone???
> Would apreciate it.   /G
> _________________________________________________________________
> Lättare att hitta drömresan med MSN Resor http://www.msn.se/resor/
> _______________________________________________
> K12OSN mailing list
> K12OSN at redhat.com
> https://www.redhat.com/mailman/listinfo/k12osn
> For more info see <http://www.k12os.org>

More information about the K12OSN mailing list