[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [K12OSN] Server vulnerable to attack




Let's try this again, there was a typo in the first email...


On Fri, 7 Jan 2005, Eric Harrison wrote:

On Fri, 7 Jan 2005, Robert Arkiletian wrote:

My server is vulnerable to attack. Any student can write a tiny program to allocate a ridiculously huge amount of memory. The server basically runs out of memory. The ulimit.sh script in the wiki works to prevent this situation under gnome but it fails to work for IceWM.

http://www.k12ltsp.org/phpwiki/index.php/limiting%20processes

Does anyone know how to make it work under IceWM? I'm using 3.1.2 (RH9)

Try this out.


Edit /etc/X11/gdm/Sessions

Right towards the top you should see this:

 	# initiate sound configs
 	if [ -f /etc/profile.d/ltsp-esound.sh ]
 	then
 	        . /etc/profile.d/ltsp-esound.sh
 	fi

Change this to:

 	# load profile
 	if [ -f /etc/profile ]
 	then
 	        . /etc/profile
 	fi


I *think* that will do the trick. Let us know if it works or not. If it works I should update the icewm packages...

-Eric


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]