[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [K12OSN] Sound continued...



On Mon, 10 Jan 2005, Trond [iso-8859-1] Mæhlum wrote:

It seems to me that most success stories with sound comes from
using nasd. I know that in Norwegian Skolelinux (Debian Woody) it
works with nasd, but it requires libaudiooss to use oss as the
sound server with nasd.

I have found libaudiooss and downloaded it, but make fails. Is
there an rpm somewhere?

libaduiooss should already be installed, it is part of the ltsp_esound_server package.

  $ locate libaudiooss
  /lib/libaudiooss.so.1
  /lib/libaudiooss.so.1.0

Yes they were installed. Looking through the howto's for Skolelinux, it seems to me that with libaudiooss should be used as the sound system with nasd.

In Skolelinux the howto instructs me to edit this file:

/etc/sysprofile.d/ltsp-sound.bash.

I should insert this:

export LD_PRELOAD="/usr/lib/audiooss/libaudiooss.so"


The ltsp-sound.bash isn't in the same place in K12LTSP, Perhaps it's missing alltoghether. Is there some way of implementing this into k12ltsp, so that I can use nasd as sound system and oss in the applications?

I tried to use mplayer with oss with nasd in k12ltsp, but it does not
play any sound.

It is in a different place in K12LTSP: /etc/profile.d/ltsp-esound.sh


libaudiooss.so is only preloaded if SOUND_DAEMON=nasd is set in
/opt/ltsp/i386/etc/lts.conf. This is the default with K12LTSP 4.x

You can double-check that LD_PRELOAD is set by logging in from a
terminal, opening a shell, and typing:

echo $LD_PRELOAD

-Eric
[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]