[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[K12OSN] VNC Reflector Not Working



Hi there everyone!

I am having some difficulty getting VNC Reflector working on our Fedora
Core 2 LTSP installation. I have followed the steps from David (which are
updated by Robert), but still no success!

I successfully built the vncreflector file and moved it to another folder,
in this case /opt/vncreflector/

In this folder, I have created the PASSWD_FILE and placed the passwords in
there as follows:
teacheruser
student

I then created the startreflector script and chmod it to allow executable
access. The script runs fine. I inserted:
/opt/vncreflector/vncreflector -p PASSWD_FILE -i PID_FILE -l 5999
HOST_INFO_FILE

I then run the vncpasswd /usr/local/share/passwd command. I enter
"student" as the password.
I then ran: chmod 755 /usr/local/share/passwd
Success so far.

I start the server with no difficulty, the server starts with no errors in
the log. It states:

VNC Reflector 1.2.4.  Copyright (C) 2001-2003 HorizonLive.com, Inc.
 
HorizonLive provides e-Learning and collaborative synchronous presentation
solutions in a totally Web-based environment.  For more information about
HorizonLive, please see our website at http://www.horizonlive.com/
 
Starting in the background, see the log file for errors and other messages.

Here's where I experience problems:

When I run vncviewer localhost:99 and enter "teacheruser". The connection
drops with the following error:

Thu Jan 20 16:01:35 2005
 CConn:       connected to host localhost port 5999
 CConnection: Server supports RFB protocol version 3.3
 CConnection: Using RFB protocol version 3.3
 
Thu Jan 20 16:01:38 2005
 main:        End of stream

There is an "End of stream" message. I have verified that the password is
correct, as when I type in the wrong password, I clearly get an
authentication error message. 

I have verified that vncserver is running, because when I type in
vncviewer localhost:1 I get a connection to the login screen.

I can also verify that when I launch vncreflector, it connects to the VNC
session because of the following log entries:

20/01/05 15:59:57 + Starting VNC Reflector 1.2.4
20/01/05 15:59:57 - Switched to the background mode
20/01/05 15:59:57 * Using only 8 first bytes of a longer password
20/01/05 15:59:57 * Host password not specified, assuming no auth
20/01/05 15:59:57 + Connecting to localhost, port 5901
20/01/05 15:59:57 + Connection established
20/01/05 15:59:58 - Remote RFB Protocol version is 3.8
20/01/05 15:59:58 * Protocol sub-version does not match (ignoring)
20/01/05 15:59:58 + No authentication required at host side
20/01/05 15:59:58 + Remote desktop geometry is 800x600
20/01/05 15:59:58 - Remote desktop name: x11
20/01/05 15:59:58 + Activating new host connection

Just to see if there is a VNC connection issue with LTSP, I changed the
host file to point to a PC with VNC Server on it, and the results were
exactly the same.. confirming that it happens with all vnc servers I try
to connect to.

Maybe I'm missing something? Does anyone have any ideas?

Thanks!

Alan Owen
Hermon School District
Hermon, ME


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]