[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [K12OSN] icewm problem with fix suggestion



On Tue, 25 Jan 2005, Patrick Healy wrote:

I use icewm exclusively on my server, but noticed since upgrading to
K12LTSP 4.2, that icewmbg and icewmtray were using a lot of resources.
Yesterday, I was running a load average of over 50, while the system
crawled.  I fixed it by:

chmod -x /usr/bin/icewmbg
chmod -x /usr/bin/icewmtray

We added a configuration option for this a little while back. You can turn off sessions (icewmbg & icewmtray) and/or nautilus by editing /etc/sysconfig/icewm

more below...

This was by using the installed version:
icewm-1.2.17-0.k12ltsp.0.4.2

I noticed that icewm.org lists version 1.2.20 as current,
and that these problems were fixed in 1.2.18pre1:

Change Log <snip>
1.2.18pre1: 2004-12-05:
* disable SupportsSemitransparency by default, this makes icewmbg exit
after setting the image and reduces memory usage
* fix CPU waste in icewm-session and icewmtray
see: http://www.icewm.org/changes.php

Any chance of an update?

Thanks,

Yeah, this has been on my TODO list for a couple of weeks now. I finished it up on a layover at SFO late Sunday night ;-)

I have not fully tested the new packages yet, so I stuck them
in my "testing" directory:

ftp://k12linux.mesd.k12.or.us/pub/K12LTSP/testing/RPMS/

Give 'em a spin and let me know if you run into any problems.

-Eric


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]