[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [K12OSN] K12LTSP 4.4.0 pre1 AND 4.2.1EL



On Fri, 2005-07-08 at 22:05 -0700, Eric Harrison wrote:
> On Sat, 9 Jul 2005, John Baillie wrote:
> 
> > On Fri, 2005-07-08 at 21:23 -0700, Eric Harrison wrote:
> >> On Sat, 9 Jul 2005, John Baillie wrote:
> >>
> >>> Eric,
> >>>
> >>> I just installed pre1 and tried yum update and got the following:
> >>>
> >>> [root gabriel yum.repos.d]# yum update
> >>> Setting up Update Process
> >>> Setting up repositories
> >>> Cannot open/read repomd.xml file for repository: k12ltsp
> >>> failure: repodata/repomd.xml from k12ltsp: [Errno 256] No more mirrors
> >>> to try.
> >>
> >> Did you try again?
> >>
> >> There is only one mirror for 4.4.0 at the moment, if you can't get
> >> to http://k12linux.mesd.k12.or.us you'll get this error. I also restarted
> >> my web server a couple of times tonight, but I did a "graceful" restart
> >> that is not supposed to be disruptive. Maybe you tried at exactly the
> >> wrong moment?
> >>
> >> Anyways, try it again and let me know of you are still having
> >> problems.
> >>
> >> I tested from several servers I have access to and they were all fine.
> >>
> >>> Theoretically we will be able yum or apt-get our way to 4.4.0 final
> >>> release?
> >>
> >> You will (no theory!) be able to yum/apt-get to 4.4.0 final.
> >> -Eric
> >
> >
> >
> > I hit the site with links (I'm ssh-ing from home)
> >
> > but still get the same error:
> >
> > [root gabriel yum.repos.d]# yum update
> > Setting up Update Process
> > Setting up repositories
> > Cannot open/read repomd.xml file for repository: k12ltsp
> > failure: repodata/repomd.xml from k12ltsp: [Errno 256] No more mirrors
> > to try.
> > [root gabriel yum.repos.d]# links  http://k12linux.mesd.k12.or.us
> 
> First, let's verify that the k12ltsp.repo file has not been modified:
> 
>  	rpm -Vf /etc/yum.repos.d/k12ltsp.repo
> 
> There should be output from this command (just a blank line).
> If you see something like this, your repository config had been
> changed:
> 
>  	S.5....T. c /etc/yum.repos.d/k12ltsp.repo
> 
> 
> Next, let's check the "mirrorlist" url in /etc/yum.repos.d/k12ltsp.repo
> 
>  	$ cat /etc/yum.repos.d/k12ltsp.repo | grep mirrorlist
>  	mirrorlist=http://k12linux.mesd.k12.or.us/mirrors/k12ltsp-4.4
> 
>  	$ links http://k12linux.mesd.k12.or.us/mirrors/k12ltsp-4.4
>  	http://k12linux.mesd.k12.or.us/K12LTSP/4.4.0/
> 
> And finally, let's check the URL for the mirror...
> 
>      $ links http://k12linux.mesd.k12.or.us/K12LTSP/4.4.0/
> 
> Here you should get a list like this:
> 
>   [DIR]  RPMS/                   23-Jun-2005 10:57    -
>   [DIR]  SRPMS/                  28-Jun-2005 08:14    -
>   [   ]  TODO                    06-Jul-2005 15:20  313
>   [DIR]  headers/                08-Jul-2005 18:47    -
>   [DIR]  i386/                   06-Jun-2005 19:45    -
>   [DIR]  iso/                    08-Jul-2005 18:32    -
>   [DIR]  repodata/               08-Jul-2005 18:45    -
>   [DIR]  updates/
> 
> If you can get this far but yum still does not work, the only thing
> that jumps to mind is that you have proxy settings set in your
> shell environment that are different than in your /etc/yum.conf. 
> Does your network require explicit proxy configurations?
> 
> > Theoretically = provided I haven't messed anything up ;-)
> >
> > BTW - This is a virgin install of pre1
> >
> > As always, Thanks
> 
> As always, I hope I was of some help.
> 
> -Eric


So far I removed all but the following from /etc/yum.repos.d

fedora-devel.repo  fedora.repo  fedora-updates.repo  
fedora-updates-testing.repo  freshrpms.repo  livna.repo

and successfully ran yum update

others are failing

It's as if they cannot be reached nor any mirrors but this should not
stop the whole process should it?

Scratching my head ---






[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]