[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[K12OSN] Samba/LDAP Management questions (Webmin,LAM,IDEALX SMC)



I have been having a nightmare trying to find a gui app to admin the
Samba/LDAP configuration, at least one that works for 100% of
operations.  I don't really care which one I get to work, just so it
works 100%.  I don't want to have to explain to whoever uses the system
why they can't click here.  I also don't want to have to use a
combination of programs to get the job done.  Just be clear this is a
fresh (acutally 3 separate fresh servers) install of K12LTSP 4.4.0 pre2
with smbldap-installer-2.0-alpha.tgz.

I was thinking of scrapping this idea and trying Fedora Directory
Server.  But then I started reading the install instructions (yeah
right, confusion instructions is better fitting).  I think this would
take me 3 weeks to try and build, so this most likely is not an option
anymore, unless someone has successfully built this and has instructions
that don't require an oversized brain and a lack of a social life to do
so.

1. I have Webmin working to edit/view existing users, but I don't have
the right settings to add them.  Anyone have an example of what settings
should be set on in the module configuration page?

2. I have LAM running and it appeared to be working, however when I
create new users, it sets up everything but their home folders.
Currently it is set to add to /home/$user.  If I create the users at the
command line with the ./smbldap-useradd -m user it works perfectly.  I
slapcat and can see the new users, I can log in as the user, but no
home.  Any thoughts?  Also I have disk quotas enabled on the /home
partition, but the Disk Quota button in user management is still grayed
out.  Any ideas on how to enable this?  Also it will not edit existing
users, say you simply want to change a users last name because of a
misspelling, doesn't work.  Also it does not seem to be compatible with
the spaces in the default groups created by the SMB/LDAP installer.  I
am unable to choose one of those groups because it shoots me an error
stating that the group is invalid because of the space, Domain Users
should be Domain_Users according to it.  But I am sure that Windows
won't work correctly unless the groups are named correctly.  Ideas?

3. I would love to get the IDEALX SMC working most of all.  But it
appears this is broken on FC4 yet. Below is a copy of the message I just
sent to 1st-imc lists IDEALX org   
----------Start Message----------
I have been trying for a few days now and cannot get IMC to run
correctly on FC4.  I get logged in, but when I click Domain
Configuration or Account Management I get a 500 Internal Server error.
I have tried many installations.  I first tried simply using the FC3
rpm's on FC4, that didn't work.  With some advice from the k12osn list I
found that installing rrdtool and openssl097a was needed.  This got me
farther and I could at least start the imc service (before I just
received and error that it couldn't find libcrypto.so.4 and libssl.so.4
when starting imc).  Now on service startup it gives me a "Not a GLOB
reference error" but start with (OK).  However I am unable to stop the
service because the system says it isn't running.  If I try to
un-install with rpm -e I get errors that it isn't installed.  Also the
login link in the upper left hand corner just directs me to a blank
page.  

So based off advice I found posted to this list about another FC4
problem I built new rpms on the FC4 machine from source with # rpmbuild
-tb imc-1.2.50-1-FC3-tar.gz, this created a new imc and a imc-common
rpm.  I installed those.  Then I rebuilt the samba-console from source
as well and installed the new samba-console rpm.  I am now where I was
with the straight FC3 rpms and simply get the 500 Internal Server error.

Is this just not ready or tested for FC4 yet?  Does anyone have this
running on FC4?

To help out I have listed the 2 errors with more detail below:

500 Internal Server Error
There was an error processing your request

A fatal error occured : 
insufficient privileges to access  /samba/conf at
plugins/Core/IMC/RequestDispatcher.pm line 52.
--------Start Web Server Error--------------
	at IMC::RequestDispatcher::dispatch
(/opt/IDEALX/imc/bin/../libexec/Pipeline/Dispatch.pm:69)
	at Pipeline::Dispatch::next
(/opt/IDEALX/imc/bin/../libexec/Pipeline.pm:90)
	at Pipeline::dispatch_loop
(/opt/IDEALX/imc/bin/../libexec/Pipeline.pm:64)
	at Pipeline::dispatch (plugins/Core/IMC/MainPipeline.pm:23)
	at IMC::MainPipeline::dispatch
(/opt/IDEALX/imc/bin/../lib/IMC/HTTP/Server.pm:180)
	at IMC::HTTP::Server::process_request
(/opt/IDEALX/imc/bin/../libexec/Net/Server.pm:108)
	at Net::Server::run_client_connection
(/opt/IDEALX/imc/bin/../libexec/Net/Server/PreFork.pm:255)
	at Net::Server::PreFork::run_child
(/opt/IDEALX/imc/bin/../libexec/Net/Server/PreFork.pm:210)
	at Net::Server::PreFork::run_n_children
(/opt/IDEALX/imc/bin/../libexec/Net/Server/PreFork.pm:132)
	at Net::Server::PreFork::loop
(/opt/IDEALX/imc/bin/../libexec/Net/Server.pm:82)
	at Net::Server::run (/opt/IDEALX/imc/bin/imc-server:25)
---------End Web Server Error-------------

---------Start Service Error--------------
[root ltsp2 ~]# /etc/init.d/imc restart
Stopping imc-server:                                       [FAILED]
Starting imc-server:    (in cleanup) Not a GLOB reference at
/opt/IDEALX/imc/bin/../libexec/IO/Socket/SSL.pm line 454.
                                                           [  OK  ]
[root ltsp2 ~]#
---------End Service Error--------------

--------------End Message--------------

Jim Kronebusch
Cotter Tech Department
507-453-5188
jim winonacotter org 

-- 
No virus found in this outgoing message.
Checked by AVG Anti-Virus.
Version: 7.0.338 / Virus Database: 267.9.7/60 - Release Date: 7/28/2005
 


-- 
This message has been scanned for viruses and
dangerous content by the Cotter Technology 
Department, and is believed to be clean.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]