[K12OSN] VNC reflector SUCCESS!! with 4.2.1EL

Robert Arkiletian robark at gmail.com
Fri Jun 17 19:40:18 UTC 2005

I am just pasting the message I sent the developers of vncreflector:

I got it to work. First I will tell you how I setup and use vncreflector. 
First with RH9 then with RHEL4

1) start vncserver. The process is listed as
  Xvnc -inetd -query localhost -once -geometry 800x600 -depth 16

then run
# vncpasswd /usr/local/share/passwd

and stick in the student password
change the permissions on this file to 755 so everyone can read it

2) start vncreflector. 
  ./vncreflector -p PASSWD_FILE -l 5999 HOST_INFO_FILE

where PASSWD_FILE has 2 passwords first one is teacher's password and
second is student's



now as teacher run 

vncviewer localhost:99

input teacher pasword
so you connect to vncreflector with keyboard and mouse

as student from thin client run 
vncviewer address_of_teacher_machine:99
type in student password and voila 

VNC server supports protocol version 3.3 (viewer 3.3)
VNC authentication succeeded
Desktop name "x11"
Connected to VNC server, using protocol version 3.3
VNC server default format:
  32 bits per pixel.
  Least significant byte first in each pixel.
  True colour: max red 255 green 255 blue 255, shift red 16 green 8 blue 0
Using default colormap which is TrueColor.  Pixel format:
  32 bits per pixel.
  Least significant byte first in each pixel.
  True colour: max red 255 green 255 blue 255, shift red 16 green 8 blue 0
Same machine: preferring raw encoding

and you see the teacher demo. But this is all under RH9

The above did *NOT* work when I tried the exact same thing with RHEL4.
 The reason I
discovered is that RH9 and RHEL4 use different versions of vncviewer. RH9 uses 
tightvnc and RHEL4 uses realvnc for the viewer. I just downloaded the
tightvnc viewer
only rpm and renamed /usr/bin/vncviewer to Xvncviewer and installed
the rpm with
--replacefiles option in rpm for the man page conflict. Then it worked
just like before. No problems.

Thank you soooooo much for making vncreflector it's super fantastic!

Just 2 question.

1) Why does real vncviewer not work and gives the message 

$vncviewer localhost:99
VNC viewer for X version 4.0 - built Feb 21 2005 15:39:30
Copyright (C) 2002-2004 RealVNC Ltd.
See http://www.realvnc.com for information on VNC.

Fri Jun 17 10:13:06 2005
 CConn:       connected to host localhost port 5999
 CConnection: Server supports RFB protocol version 3.3
 CConnection: Using RFB protocol version 3.3

Fri Jun 17 10:13:10 2005
 main:        End of stream

Something to note (but it made no difference) was Xvnc is started on RHEL4 with

/usr/bin/Xvnc -inetd -once -query localhost -fp unix/:7100
-SecurityTypes None -geometry 800x600 -depth 16

which is different from RH9 wrt -SecurityTypes and -fp (but this did
not prevent things from working once the viewer was changed)

2) Also,  I noticed 

Same machine: preferring raw encoding

I suspect vnc is simply using raw encoding because it thinks the
display is on the same machine. But since this display is remote it
does go over the
network. So I figure it could make use of a better encoding method.
How can I speed things up because there is a definite lag on all
student displays
even using a fast switch.

Thank you for reading this long post.

Robert Arkiletian
C++ GUI tutorial http://fltk.org/links.php?V19

More information about the K12OSN mailing list