[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[K12OSN] after update WINE not working on 4.2.0 SOLVED --MORE



In april there was a thread here regading wine-trouble after upgrading
to FC3. The problem was that when running wine, this happened:

wine: failed to initialize: /usr/lib/wine/ntdll.dll.so: failed to map
segment from shared object: Cannot allocate memory.

I answered to this thread, because I'm a heavy wine-user and did not
have this trouble at all in FC3. Then the solution was presented, to
downgrade initscripts.

But now I have installed Centos4 with K12LTSP built in, and now I'm
getting this error as well. It also happens on a "real" RHEL4 install.
I'm using the latest wine rpm for CentOS4.

I tried the initscript downgrade, but nothing changed. What I can do is
when I'm root, is to do ulimit -v unlimited before I call wine. Then it
works for root - in that shell.

I am not able to set this variable for a user, or to set it globally,
because I don't know how. This is mentioned as a wine-bug, but no
solution is presented other than pointing to the ulimit command.

Can someone please help me out with this one?

best regards
Trond Maehlum





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]