[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [K12OSN] verynice won't control python



On Sun, 13 Nov 2005, Peter Hartmann wrote:

Thanks for getting back to me.  Unfortunately, none of that worked.  I
have a feeling this has to do with the convoluted way that I got this
working.  When I install childsplay and pygame with yum everything
looks good but it won't actually run. Running from the command line I
get this:

[admin k12linux ~]$ /usr/lib/python2.3/site-packages/pygame/base.so:
cannot open shared object file: No such file or directory

 Childsplay depends on pygame.

 You must first install the pygame package.
Due to the fact that this package has some tricky
dependencies, you better install the one that came with your distribution.

Mind you it's there and base.so has no permissions problems. So, I
installed pygame from source, picked up it's x86_64 deps and installed
your RPM with -nodeps since it wouldn't see pygame in lib64.  Pygame
is now in /usr/lib64/python2.3/site-packages/.  I tried installing
childsplay from source but I only get two of the games.  One of which
is the cpu offenders and it remains to be so.  I bet if I use your k12
pygame and childsplay the cpu problem will go away.   Why is it that
they aren't working together for me? Any help you could give would be
great.  The kids freakin' LOVE this game.


I see that you are running it on a x86_64 box. I did my testing on a
i386 box.

Note that my childsplay RPM contains both childsplay and the
childsplay plugins. If you install from source, be sure to install both.

For what is worth, I'm working on full x86_64 builds of K12LTSP,
including ISOs. I'm not sure when they will be ready, but it will
be at least a couple of weeks.

-Eric



On 11/13/05, Eric Harrison <eharrison mail mesd k12 or us> wrote:
On Sat, 12 Nov 2005, Peter Hartmann wrote:

I have bad situation involving Childsplay.  In particular, when the
game top row, 5th from the left is played, the cpu usage for that
users python process goes up to about 90%.  I added this to
verynice.conf and restarted verynice:

hungryexe "/usr/bin/childsplay"
hungryexe "/usr/bin/python"

It has no effect on python.  What's going on here, do you know?

Thanks,
Peter

I don't see the same problem on my server. But here are
a few things to try:

1) If you want childsplay to always run "nice", edit the
script /usr/bin/childsplay  and change it from:

        python /usr/lib/childsplay/childsplay.py $* &

to:

    nice python /usr/lib/childsplay/childsplay.py $* &


2) Try out the latest version of childsplay, which I'm
getting ready to add to the next minor release of K12LTSP:


    ftp://k12linux.mesd.k12.or.us/pub/K12LTSP/testing/RPMS/childsplay-0.81.1-1.k12ltsp.4.4.2.noarch.rpm

3) It may make a difference if your verynice.conf has
    "python" rather than "/usr/bin/python", and you probably
    want it as a "badexe" rather than "hungryexe":

        badexe "python"

-Eric



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]