[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [K12OSN] PostSession script, rm command and user directories



FOR GOD SAKE !

I cryed ... hit my head at the wall and cryed again.
Why ?

1. Started thinking WHY it leaves files and folders to their places ?
2. Why doesn't it work by the battern ? Sometimes erases one things and sometimes does not ?
3. Why it needs more rm commands than the old system !?

So with my stupid head an "no-ideas" thinking I wrote in some sleep commands.
***********************
rm -rf /home/terminal9/*
sleep 2
rm - rf /home/terminal9/.*
sleep 2
rm -rf /home/terminal9
sleep 4

tar command
***********************
what happened ? All the directories were erased !! For god sake.
Now I had a working script but logout took place for 8 + 1 seconds. Not nice. What about if I change first two sleep intervals to 1 second and leave the last one as is ? So logout should last about 6 seconds. It was faster and like usual ... no success. Folders and files made by the user were NOT erased :'(

cryed some more

So I was thinking that I need a break and went to make some coffe. When I returned, changed the intrervals back to values that worked, logged in, made some foldest and files, logged out again ... logged in and ... NOT ERASED !!! :'(

So the intervals were the same as these that worked last time but now they do not work. This is weird and unusual problem. What's going one ? My server has been changed to super-server that works so fast that scripts are unable to follow it !? This just makes me cry ... :(

Does anyone have more ideas what to change/try/eliminate ?

Meelis
---
meelis nlib ee
[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]