[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [K12OSN] More oddities with K12LTSP 6.0 rc2



Eric Harrison wrote:
Peter Deakin wrote:

I have done a standard install ltsp 6 rc2, setting host name to LTSP-2 using 192.168.0.254 setting DNS and default gateway. on first boot sendmail took about 2 min to start and smclient about a 1 min. everything seem OK workstations booted up and I was able to log on with the one account I had created.

Investigating sendmail I noted that the /etc/hosts had some strange entries at the beginning something like: ...8 loclhost.localdomain, this was repeated. There was no 127.0.0.1 and LTSP-2 had an IP of 208.67.(can't remember the rest, think it ended in 40)-this was similar to the DNS serevers(208.67.222.222) that I entered at install.

I edited hosts file as below

127.0.0.1    LTSP-2    localhost.localdomain    localhost
192.168.0.1    ws001.ltsp    ws001
192.168.0.2    ws002.ltsp    ws002
etc to
192.168.0.253    ws253.ltsp    ws253
192.168.0.254    server.ltsp    server

rebooted the server and sendmail loaded without any problems

but now when I try to log on with a user the home folder can't be found.

I ran ltspadmin and it reported that

/etc/hosts /etc/hosts.allow /etc/exports were not configured

checking the files they all seemed ok, but I ran the configuration anyway which double entered everything in those files, but ltspadmin was happy. Rebooted the server some complaints about the double entries in exports, and still no home folders.

I have edited out the double entries and now ltspadmin is again reporting that those files are not configured. I have not tried it again since as I am now at home. I guess it may be just one of those odd installation glitches, or may be that odd IP address has got in some config file and editing it out of hosts has screwed things up? As there is no data on there yet I may just do a reinstall, but if anyone can shed any light as to what may have gone wrong or has an easy fix?

Peter Deakin



My guess is that you selected IPv6 ("....8 localhost.localdomain" looks a lot like a IPv6 loopback address). I can envision all sorts of weird things happing if you have half your config files with a IPv4 address and the other half with a IPv6 address.


If you do a reinstall, make sure not to select that you use IPv6.


If this were my system, I'd run "System -> Administration -> Network" and make sure that each interface is configured properly (i.e. "Enable IPv6..." is not checked if you don't use IPv6, the correct IP/Netmask/Gateway are set on your static IP addresses, etc, etc).

I'd then check that /etc/fstab, /etc/hosts, /etc/exports, /etc/resolv.conf & /etc/dhcpd-k12ltsp.conf are all correct.

-Eric



Thanks for the pointers Eric, I checked all the files you suggested but I couldn't find anything amiss. I have done a reinstall today, disabling the IPv6 option and everything went went OK. I think you were correct in your guess about IPv6, I almost missed the option the second time round!

Is the any advantage / disadvantage in not installing with IPv6?

One issue though even installing with IPv4 the first entry in hosts was

::1 LTSP-2 localhost.localdomain localhost Webmin was not happy with this arrangement and refused to play until I modified it to

127.0.0.1  LTSP-2 localhost.localdomain localhost

This doesn't seemed to have caused any problems yet with the rest of the system the terminal boots OK and the home folder in found.

Thanks for your many hours of hard work in making K12ltsp the superb software that it is.

Best Regards

Peter


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]