[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[K12OSN] smbldap on K12LTSP-6 errors



Everything goes fine until this part of smbldap configure.

It seems to be looking for Crypt/SmbHash but can't find it.

cp "/etc/opt/IDEALX/smbldap-tools/smbldap.conf" "/etc/opt/IDEALX/smbldap-tools/smbldap.conf-Mon_Jan__1_01_42_55_2007.bak"
Running smbldap-populate...
printf "password\npassword" | smbldap-populate -a root -u 10000 -g 10000
Can't locate Crypt/SmbHash.pm in @INC (@INC contains: /opt/IDEALX/sbin/ /usr/lib/perl5/site_perl/5.8.8/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.7/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.6/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.5/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.8 /usr/lib/perl5/site_perl/5.8.7 /usr/lib/perl5/site_perl/5.8.6 /usr/lib/perl5/site_perl/5.8.5 /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl/5.8.8/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.7/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.6/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.5/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.8 /usr/lib/perl5/vendor_perl/5.8.7 /usr/lib/perl5/vendor_perl/5.8.6 /usr/lib/perl5/vendor_perl/5.8.5 /usr/lib/perl5/vendor_perl /usr/lib/perl5/5.8.8/i386-linux-thread-multi /usr/lib/perl5/5.8.8 .) at /opt/IDEALX/sbin//smbldap_tools.pm line 5, <DATA> line 225.
BEGIN failed--compilation aborted at /opt/IDEALX/sbin//smbldap_tools.pm line 5, <DATA> line 225.
Compilation failed in require at /opt/IDEALX/sbin/smbldap-populate line 35, <DATA> line 225.
BEGIN failed--compilation aborted at /opt/IDEALX/sbin/smbldap-populate line 35, <DATA> line 225.
failure!
I'm stopping here because this is bad.

I ran this command to try to find where this file is
[root k12ltsp1 smbldap-installer]# locate SmbHash.pm
/usr/lib/perl5/vendor_perl/5.8.3/Crypt/SmbHash.pm

I then created a link
#ln -s /usr/lib/perl5/vendor_perl/5.8.3/Crypt /usr/lib/perl5/vendor_perl/5.8.8/Crypt/

Was this a good idea?

Now when I run it complains it can find the domain SID.

[root k12ltsp1 smbldap-installer]# /opt/IDEALX/sbin/smbldap_tools.pm
Unable to determine domain SID: please edit your smbldap.conf,
  or start your samba server for a few minutes to allow for SID generation to proceed

What now?

Thanks. Happy New Year.
Krsnendu dasa

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]