[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [K12OSN] smbldap on K12LTSP-6 errors



If I stop ldap then smb runs but as soon as I restart ldap I get the "smbd dead but pid file exists" message again. When smb is running I can't get a sid because smb tries to call ldap which is not running.
So there is something in ldap that is making smb crash.
When I had this problem in the past it was because my ldif file was corrupted. Slapadd from backup fixed it. But that was with an installed system and I can't get to that stage yet.

[root k12ltsp1 smbldap-installer]# service ldap stop
Stopping slapd:                                            [OK]
[root k12ltsp1 smbldap-installer]# service smb restart
Shutting down SMB services:                                [  OK  ]
Shutting down NMB services:                                [  OK  ]
Starting SMB services:                                     [  OK  ]
Starting NMB services:                                     [  OK  ]
[root k12ltsp1 smbldap-installer]# service smb status
smbd (pid 16207) is running...
nmbd (pid 16211 16210) is running...
[root k12ltsp1 smbldap-installer]# service ldap start
Checking configuration files for slapd:  config file testing succeeded
                                                           [  OK  ]
Starting slapd:                                            [  OK  ]
[root k12ltsp1 smbldap-installer]# service smb status
smbd dead but pid file exists
nmbd (pid 16211 16210) is running...



On 01/01/07, Krsnendu dasa <krsnendu108 gmail com> wrote:
samba is not running.

[root k12ltsp1 smbldap-installer]# service smb start
Starting SMB services:                                     [  OK  ]
Starting NMB services:                                     [  OK  ]
[root k12ltsp1 smbldap-installer]# net getlocalsid
[2007/01/01 06:34:15, 0] utils/net.c:net_getlocalsid(583)
  Can't fetch domain SID for name: HKSCHOOL-PDC
[root k12ltsp1 smbldap-installer]# service smb status
smbd dead but pid file exists
nmbd (pid 14661 14659) is running...



On 01/01/07, cliebow midmaine com <cliebow midmaine com> wrote:
net getlocalsid should spit out the sid if samaba is running..that needs
to be  in smbldap.conf


_______________________________________________
K12OSN mailing list
K12OSN redhat com
https://www.redhat.com/mailman/listinfo/k12osn
For more info see <http://www.k12os.org>



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]