[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [K12OSN] which XSERVER for riva128?



On Tue, 31 Jan 2006, Robert Arkiletian wrote:

On 1/31/06, Petre Scheie <petre maltzen net> wrote:
I've got a client workstation that can't seem to start its X server.
When X tries to start, it fails but  reports that the machine has a
RIVA128 chip but it can't seem to start the X server (I forget the
actual error message).  I'm suprised that the XFree 4 drivers won't
work.  In any event, I can hardcode the X server for this workstation.
Does anyone know which one I should use for the RIVA128?

Yes, all my clients are RIVA128. The driver is "nv" but "auto" works
just fine so I don't think you need to hardcode the driver. I bet the
problem you are having is that the RIVA128 does not support 16 bit
color. Your have to use 24 bit, which looks better anyway.


To set "24 bit color" on a specific workstation, append a section
such as this to your /opt/ltsp/i386/etc/lts.conf

[00:50:56:59:7F:81]
    X_COLOR_DEPTH = 24

(where "00:50:56:59:7F:81" is the MAC address of the client. Alternatively,
 you can use the IP address or the host name of the client if you have
 either of those hard-coded. Using the MAC address is the most reliable)


If you want all workstations to use 24-bit color (looks better, but uses
more network bandwidth), then add the "X_COLOR_DEPTH = 24" line to the "[Default]" section at the top of /opt/ltsp/i386/etc/lts.conf

-Eric


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]