[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [K12OSN] how to create etherboot CD



On Fri, 10 Feb 2006, Petre Scheie wrote:



Les Mikesell wrote:
On Fri, 2006-02-10 at 13:26, Petre Scheie wrote:

I hacked someone else's CD image, don't remember the exact details (it
is in the archives...).

Give this a spin:

ftp://k12linux.mesd.k12.or.us/pub/K12LTSP/testing/eb_pci.iso

-Eric
Well, that works a bit better than my CDs: FreeDOS seems to load, and I get the screen full of dots (is this the tftp stage?), ending in 'done'. But then the next line says 'Issuing RESET:' and it just hangs there.

That one works for me in an old Capuccino mini-book PC.  The dots
should be the tftp part and after the 'done' you should get
something like
mknbi-1.4.0/first32.c (GPP)
Top of ramdisk is 0X07EE0000.

--
 Les Mikesell
   les futuresource com

Perhaps it's just a problem with the Dell Optiplex I tested it on. The machine this is actually for, a Micron (does Micron even make PCs any more?) is at another site, so I'll take the CD there this weekend and try it. Interestingly, I tried the PXES bootable CD in the Dell, choosing XDM at the boot menu, and it works just fine, boots up the login screen from the server in just a few seconds.

(BTW Eric, I tried to google for your original messages about the CD but couldn't find any.)

I thought there was a message detailing the changes I made. Doesn't
appear to be the case (and I can't remember much about it, probably
just a simple dos batch file edit).

Here's the original post, grep didn't turn up anything else in my
mailbox. Maybe more in the thread in the list archives....


-------------

Message-ID: <423F2C2A 5050507 mail mesd k12 or us>
Date: Mon, 21 Mar 2005 12:18:50 -0800
From: Eric Harrison <eharrison mail mesd k12 or us>
User-Agent: Mozilla Thunderbird 0.9 (X11/20041127)
X-Accept-Language: en-us, en
MIME-Version: 1.0
To: "Support list for opensource software in schools." <k12osn redhat com>
Subject: Re: [K12OSN] universal etherboot iso?
References: <8883FBEA06AD6D4CB9C780772C08E282119F56 goodwill1 goodwill lan> <1111435379 15579 38 camel moola futuresource com>
In-Reply-To: <1111435379 15579 38 camel moola futuresource com>

Les Mikesell wrote:
On Mon, 2005-03-21 at 12:46, David H. Barr wrote:


image to start with.  What's an eb2hd?   The reason I need this is

[snip]


I want to be able to load other things on the HD.

Etherboot to (2) Hard Disk: http://etherboot.anadex.de/  It's what I used
to set up my 5-station test lab.  I downloaded the floppy image, then used
Nero to burn a bootable CD of it.


That worked in terms of k3b accepting it as a boot image and making a
bootable iso.  However, it wants to install a copy on the HD and all I
want to do is netboot directly WDXB2500JBRNNfrom the iso.  I think the
difference is that the eb2hd floppy image uses freedos/syslinux to boot
where the floppy I want to use is just like an etherboot ROM image with
no separate loader - and k3b (etc) doesn't like it.  I guess I need
the etherboot image in a .com file format with a dos framework and
autoexec.bat to load it.

I was rather displeased to see that it wanted to repartion/format my
harddrive :-(

I rebuilt it to just load etherboot off the iso image. This only works
for PCI nics, however, no go for old ISA cards. Still it might be useful
to someone. I put my hacked version here:

        ftp://k12linux.mesd.k12.or.us/pub/K12LTSP/testing/eb_pci.iso

-Eric



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]