[K12OSN] server not forwarding packets for Windows clients

Petre Scheie petre at maltzen.net
Mon Jan 30 20:54:38 UTC 2006

Les Mikesell wrote:
> On Mon, 2006-01-30 at 13:25, Petre Scheie wrote:
>>I've got a k12ltsp server providing DHCP addresses to a bunch of Windows machines.  The 
>>intent is to turn the Windows boxes into thin clients with Universal Boot Floppies(tm) 
>>or at least dual-boot systems.  The server is a two-nic config, and I installed it this 
>>past weekend.  But today, when people are back in the office, the Windows clients are 
>>getting addresses from the DHCP on the server, but any requests directed to the internet 
>>are not getting any response.  I ran tracrert from a W2K box: it got as far as the 
>>server but no further.  It's as if the server isn't forwarding any requests that come in 
>>eth1 to eth0.  I turned off iptables, but that made no difference.  It seems something 
>>is off in the routing/NAT'ing/masquerading, but what?
> Does 'chkconfig --list nat' show that it is on in runlevel 5?
> If not, do:
> chkconfig nat on
> service nat start
> But I thought this should be enabled in a default k12ltsp install.
I think it is.  I built the server in my basement and successfully tested it with some 
thin clients; but I didn't try any Windows clients.  But I think something else must be 
going on because when I logged in at the console, while I could ping things like google 
& yahoo, firefox had trouble with them: first it wouldn't load any thing, then after 
shutting it down and restarting it, it could bring up a google page, but not yahoo; shut 
it down and restart it again and google and yahoo are accessible, but not others.  I ran 
'host' on those & other websites and while I'd get an answer, I also got an error about 
the parser  receiving misformatted data.  In /etc/resolv.conf, there were two resolver 
addresses: the Linksys router, and the DNS server of the ISP.  I commented out the 
Linksys address, and then 'host' didn't get any more errors, but users still couldn't 
connect to the internet.  Here's how the network is layed out; it doesn't look like 
anything special to me.

Internet-->ActionTec DSL bridge-->LinkSys Router w/wireless--> \

-->8-port switch-->K12ltsp-->24-port switch-->clients

I suppose I could check for bad packets and cables.  Any other ideas of things to look for?

More information about the K12OSN mailing list