[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [K12OSN] gnome login errors [solved]



argh! yes, i'm an idiot.

i'm hosting the ldap on fc3, but my acls were locking out read access to users login shells! did a 'getent passwd' and noticed the shells weren't appearing in the list.

thanks for pointing me in the right direction, brad. sometimes you just can't see the wood for the trees. ;-)

john

 --- On Fri 01/06, Brad Johnson < bjohnson independence k12 ia us > wrote:
From: Brad Johnson [mailto: bjohnson independence k12 ia us]
To: jhalfpenny excite com, k12osn redhat com
Date: Fri, 6 Jan 2006 15:35:06 -0600
Subject: Re: [K12OSN] gnome login errors

what is hosting your ldap services?? OS X?  If so, make sure your  <br>users have a default login shell chosen.  By default, my users on my  <br>os x server did not have a login shell chosen, and I rangled with  <br>this exact issue for months before I figured this out.<br><br>Brad<br><br>On Jan 6, 2006, at 9:09 AM, John Halfpenny wrote:<br><br>><br>> hi. i'm having a real problem with gnome on a default install of  <br>> k12 4.4.1.<br>><br>> i can only login to gnome with ldap users if i login as runlevel 3  <br>> first and then startx manually, root works fine from runlevel 5  <br>> startup.<br>><br>> after being told my login lasted for less than 10 seconds, the  <br>> output of my error is this<br>><br>> /etc/X11/gdm/PreSession/Default: Registering your session with wtmp  <br>> and utmp<br>> /etc/X11/gdm/PreSession/Default: running: /usr/X11R6/bin/sessreg -a  <br>> -w /var/log/wtmp -u /var/run/utmp -x "/var/gdm/:0.Xservers" -h "" - <br>> l ":0" "john"<br>> 
/etc/X11/xdm/Xsession: line 76: /usr/bin/ssh-agent /usr/bin/dbus- <br>> launch --exit-with-session gnome-session: No such file or directory<br>> /etc/X11/xdm/Xsession: line 76: exec: /usr/bin/ssh-agent /usr/bin/ <br>> dbus-launch --exit-with-session gnome-session: No such file or  <br>> directory<br>><br>> i've been through umpteen searches on google and am totally stumped  <br>> as to why i'm receiving this error. it seems to do it on my FC3  <br>> install and K12LTSP.<br>><br>> having been at it for the best part of two days i have tried all  <br>> these things-<br>><br>> checked permissions on /tmp<br>> checked permissions and availability on users home folder<br>> checked disk space on both nfs and local server<br>> uninstalled / reinstalled gnome-session<br>> uninstalled / reinstalled gdm<br>><br>> i don't know which file it is referring to in the error, ssh-agent,  <br>> dbus-launch and gnome-session are all in /usr/bin.<br>><br>> if anyone out there has any idea at al!
l 
why this is happening i  <br>> would be extremely grateful- as i've mentioned my users can all log  <br>> into run level 3, and they can all run gnome if the machine starts  <br>> up in run level 3 before starting x!<br>><br>> how odd!<br>><br>> TIA<br>><br>> john<br>><br>> _______________________________________________<br>> Join Excite! - http://www.excite.com<br>> The most personalized portal on the Web!<br>><br>><br>> _______________________________________________<br>> K12OSN mailing list<br>> K12OSN redhat com<br>> https://www.redhat.com/mailman/listinfo/k12osn<br>> For more info see <http://www.k12os.org><br>><br><br>

_______________________________________________
Join Excite! - http://www.excite.com
The most personalized portal on the Web!



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]