[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [K12OSN] K12LTSP V(?) for updated MOODLE apps



Alan Hodson wrote:
> We expect a robust demand for Moodle in the servers running K12LTSP. My
> question is, what is the process for requesting/suggesting upgrades to
> 'yum' for the latest Moodle, php and MySQL, so that say v.4.4.2 (or
> newer) run the latest apps needed? As far as I can tell my 'yum updates'
> are a couple of versions behind in these apps.

v4.4.2 will have roughly the versions of PHP and MySQL that were current
when Fedora Core 4 shipped. The newest version of Moodle, 1.6, requires
a newer version of PHP. I'd guess that MySQL/PHP unlikely to be upgraded
beyond the current version given in impending legacy status of FC4 (in a
little over a week).

FC5 (and thus K12LTSP v5) has up-to-date versions of MySQL and PHP:
[dyoung ltsp ~]$ yum list mysql-server php
...snip....
Installed Packages
mysql-server.i386                    5.0.22-1.FC5.1         installed
php.i386                             5.1.4-1                installed

These fulfill the requirements for Moodle v1.6.

Moodle 1.5.3 is in extras; if you're waiting for 1.6, you could ask on
the Fedora-extras mailing list if you're using the Fedora package. When
I maintained a Moodle server there wasn't yet a package in Extras, but
it was easy to install/upgrade by hand. Just follow the docs:
http://docs.moodle.org/en/Upgrading

-- 
Dan Young <dyoung mesd k12 or us>
Multnomah ESD - Technology Services
503-257-1562


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]