[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[K12OSN] k12 4.4.1 yum errors and missing deps



Hi Group,

I have had errors trying to run a yum update since I first installed k12
4.4.1 a couple of months ago.  I tried chipping away at the missing
dependencies by hand, but usually found I could not pull them in for one
reason or another.  I did read on a Fedora list that bits of yum are
broken, but I had hoped they would be fixed by now.  

I have a stock k12 4.4.1 install with all default repos enabled, and I
went berserk doing a 'kitchen sink' install from the beginning.  I have
tried a yum update numerous times but it always fails with the same type
of missing dependencies as per the terminal output below: 

------------yum update output----------
Error: Missing Dependency: libdbus-1.so.1 is needed by package liferea
Error: Missing Dependency: libdbus-glib-1.so.1 is needed by package
liferea
Error: Missing Dependency: libneon.so.24 is needed by package apt
Error: Missing Dependency: libvte.so.4 is needed by package gtkterm
Error: Missing Dependency: libMagick.so.6 is needed by package transcode
Error: Missing Dependency: libMagick.so.6 is needed by package pstoedit
Error: Missing Dependency: ImageMagick = 6.2.2.0-3.fc4.2 is needed by
package ImageMagick-c++
Error: Missing Dependency: libWand.so.6 is needed by package
ImageMagick-c++
Error: Missing Dependency: libMagick.so.6 is needed by package
ImageMagick-c++
Error: Unable to satisfy dependencies
Error: Package liferea needs libdbus-glib-1.so.1, this is not available.
Error: Package ImageMagick-c++ needs libMagick.so.6, this is not
available.
Error: Package xine needs libcrypto.so.5, this is not available.
Error: Package perl-Net-SSLeay needs libssl.so.5, this is not available.
Error: Package ImageMagick-c++ needs ImageMagick = 6.2.2.0-3.fc4.2, this
is not available.
Error: Package kudzu needs kernel < 2.6.13, this is not available.
Error: Package apt needs libssl.so.5, this is not available.
Error: Package pstoedit needs libMagick.so.6, this is not available.
Error: Package scribus needs libcrypto.so.5, this is not available.
Error: Package transcode needs libMagick.so.6, this is not available.
Error: Package apt needs libcrypto.so.5, this is not available.
Error: Package liferea needs libdbus-1.so.1, this is not available.
Error: Package apt needs libneon.so.24, this is not available.
Error: Package gtkterm needs libvte.so.4, this is not available.
Error: Package perl-Net-SSLeay needs libcrypto.so.5, this is not
available.
Error: Package ImageMagick-c++ needs libWand.so.6, this is not
available.
Error: Package scribus needs libssl.so.5, this is not available.
Error: Package xine needs libssl.so.5, this is not available.
----------------------------

Of course, the update fails because of this.  I've tried pulling in some
of those 'lib' files, but either they can't be found or they fail to
change the update situation.  Any suggestions?  Thanks.

Gavin


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]