[K12OSN] smbldap-installer in FC5 64bit (Ken Arany)

Matt Oquist moquist at majen.net
Wed Jun 28 16:56:31 UTC 2006

> Date: Tue, 27 Jun 2006 12:17:42 -0400
> From: Ken Arany <ken at gccsda.com>
> Subject: [K12OSN] smbldap-installer in FC5 64bit

> I have been working with Beta10 of 5.0 64bit and everything has been 
> working until I tried to install smbldap-installer. I know that the 
> current version of smbldap doesn't claim to install on the new version 
> yet, but I tried it anyway.

That's the spirit! :)

Yes, you've identified the same problems I have as I work on FC5
support. I've taken care of the pid file in my dev version, but I'm
still not sure what's timing out while dbus starts.

Oh - one other thing is that the "min passwd length" setting needs to
be removed from smb.conf.

I haven't uploaded the dev version anywhere yet, but I aim to do that
in the next few days. (I just got back from MoodleMootNE, so I have
until Tuesday to do it (and several other things :) before I head off
to NECC.)

OK...so I uploaded my dev version to

It's mostly working. The dbus ("System Messaging Bus") timeout during
boot goes away if you entirely remove ldap from nsswitch.conf, but
I haven't been able to track it down further than that. Also, you must
run system-config-security (or something like that) to turn off the
firewall before you can join any Winders(TM) machines to the domain.

I'll be working on it, too, but let me know if you figure anything
out. :)


> The problem I have run into is that openldap 
> seems to have changed some of their file structure and now slapd.pid 
> lives in /var/run/openldap/slapd.pid instead of /var/run/slapd.pid. I 
> can install the smbldap-installer portion and everything still works, 
> but after I modified the template for slapd.conf to reflect the new 
> location of the slapd.pid, the smbldap-configure script runs once. 
> However, when I try to reboot the system, it takes a long time trying to 
> start "namd" and then again a long time for "System Messagebus" and 
> thirdly on "ldap". I have tried to follow the script and see what other 
> things are being changed by the script, but I'm coming up with head 
> scatchings. Even if I tell ldap not to start at boot up it still takes a 
> long time (close to 40mins)  Has anyone else had this problem? if so do 
> you have a solution yet. Is there a new smbldap -installer being worked 
> on or should i uninstall the current openldap and install an older 
> version? I have 9 new servers that need to be installed into 9 of my 
> elementary school, hopefully by the end of the summer. Any help is much 
> appreciated and thanks in advance.
> Ken Arany
> Georgia-Cumberland Conference of SDA
> IT Services
> ken at gccsda.org
Open Source Software Engineering Consultant
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 189 bytes
Desc: Digital signature
URL: <http://listman.redhat.com/archives/k12osn/attachments/20060628/5a908cf6/attachment.sig>

More information about the K12OSN mailing list