[K12OSN] v5 beta9 install notes

Eric Harrison eharrison at mail.mesd.k12.or.us
Fri Jun 30 17:09:07 UTC 2006

On Fri, 30 Jun 2006, William Fragakis wrote:

> Eric,
> I tried installing via ftp last night and my gdm is dead, too. Plain
> vanilla install using the defaults. I tried using yum update and that
> made it worse as a bunch of cyrillic characters go across the screen
> before I can copy down the error.
> I'd previously installed beta4 on the same system with no hitch but had
> issues with yumex so tried to do a fresh install instead.
> Also a lot of errors are thrown during boot - access denied and services
> failing. Could this be due to SELinux?

That sounds like the font server issue I had on my laptop, /etc/X11/fs/config
was missing. I had a /etc/X11/fs/config.rpmsave that I copied to 
/etc/X11/fs/config and all was well. (look for a /etc/X11/fs/config.rpmnew
if you don't see a config.rpmsave).

> I don't have the command line chops Jim does to sort things out at the
> moment as we are about to be off for the weekend.

I'm off as well. Back online in a day or two ;-)


> Regards,
> William
> On Fri, 2006-06-30 at 12:00 -0400, k12osn-request at redhat.com wrote:
>> Message: 7
>> Date: Thu, 29 Jun 2006 13:40:33 -0700 (PDT)
>> From: Eric Harrison <eharrison at mail.mesd.k12.or.us>
>> Subject: Re: [K12OSN] v5 beta9 install notes
>> To: "Support list for opensource software in schools."
>>         <k12osn at redhat.com>
>> Message-ID:
>>         <Pine.LNX.4.61.0606291329380.22049 at eharrison.mesd.k12.or.us>
>> Content-Type: TEXT/PLAIN; charset=US-ASCII; format=flowed
>> On Wed 28 Jun, James P. Kinney III wrote:
>>> I had python "issues" installing beta 9 (i386 version). The anaconda
>>> would crash complaining about a gui library issue. It happened 2
>> times
>>> at about the same spot (disk 2). I was not able to capture the exact
>>> error as that machine had no working floppy drive. I was able to
>> install
>>> with the text method.
>>> The yum update process cause gdm issues. The k12ltsp version removed
>> the
>>> file that controls the graphics display mapping and gdm would no
>> longer
>>> start. I pulled an older version over and renamed it for the new
>> gnome
>>> version and recovered. (can't locate notes on this event at the
>> moment
>>> for the file name... Hmm.)
>> No GDM issues here. Let me know if you can repeat the problem & if you
>> can let me know what file fixed it.
>> I had a problem with the latest font server upgrade (xorg-x11-xfs)
>> on my laptop, but I chalked that one up as my problem (heavily abused
>> computer + I ran out of disk space right about the same time as the
>> font server issue). All of my other upgrades went fine. I'm doing
>> a series of tests today, I'll keep my eyes open.
>>> Many of the yum updates in the k12ltsp repo failed to successfully
>>> complete post-install scripts. The default setting in yumex (and
>> yum)
>>> was to remove after install so the package was no longer around to
>> work
>>> by hand. Add to this the gui for yumex no longer worked after the
>>> update. I used rpm -e to remove it (yumex), turned off the k12ltsp
>> repo
>>> and reinstalled yumex from the Fedora repo.
>> The yumex package in the K12LTSP repo is the same package as the
>> Fedora
>> repo. I'll double-check the MD5SUM to make sure it is 100% identical.
>>> Please note: these were mostly minor issues for me (except the lost
>>> gnome that threw me for a loop for hours!) I have tested this on
>> several
>>> different TC system and it works very well. An impromptu demo was a
>> nice
>>> surprise as sound "just worked".
>>> Release date on v5 final?
>> Probably pretty soon. I hope to have a close-to-last beta release out
>> today. I'm working on a number of minor packaging refinements that
>> won't
>> make a difference to most people + doing a lot of testing.
>> There is a known bug in the new USB thumbdrive access feature. If Jim
>> doesn't put out an official update real-soon-now, I'll bug him for a
>> patch ;-)
>> -Eric

More information about the K12OSN mailing list