[K12OSN] yum update problem

Julius Szelagiewicz julius at turtle.com
Fri Jun 30 18:39:57 UTC 2006

> Julius Szelagiewicz wrote:
>> 	when I run yum update on a k12ltsp 4.x (fc3) server, I get an
>> error after all the transaction checks and downloads:
>> warning: rpmts_HdrFromFdno: V3 DSA signature: NOKEY, key ID 731002fa
>> public key not available for udev-039-10.FC3.9.legacy.i386.rpm
>                                                  ^^^^^^
>> Retrieving GPG key from http://k12linux.mesd.k12.or.us/K12LTSP-GPG-KEY
>> The GPG key at http://k12linux.mesd.k12.or.us/K12LTSP-GPG-KEY
>> (0xF1A2DED5)
>> is already installed but is not the correct key for this package.
>> Check that this is the correct key for the "K12LTSP" repository.
>> Any suggestions on how to resolve it and actually perform the update?
> Since FC3 is no longer getting updates from Fedora proper, Eric is
> pulling in Fedora Legacy packages. You need the Fedora Legacy GPG key
> installed.
> rpm --import http://www.fedoralegacy.org/FEDORA-LEGACY-GPG-KEY
> --
> Dan Young <dyoung at mesd.k12.or.us>
Thank you Dan. Worked like magic!

More information about the K12OSN mailing list