[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [K12OSN] LTSP 4.4.1 client booting fails



On Mon, 2006-06-05 at 16:52 -0700, Hung Phan wrote:
> I'm using K12LTSP 4.4.1 (Fedora Core 4) with Neoware C50 thin client.
> The server obtain IP through DHCP (and it works) and serve out  
> through eth2 (because eth0 inboard is dead, it is Intel Pro 100  
> eepro100 card)
> 
> The client cannot boot, it keep running tftp......until it timeout.  
> When the client boots, I run tail -f /var/log/messages. It shows the  
> client obtain an IP, and eventually timeout with PXE.
> 
> Check tftpd, it's running. Check xinetd.d/tftp, nothing changes in  
> the file.
> 
> When I check the default kernel at /tftpboot/lts/pxe, it doesn't  
> exist. Only the kernel with options compiled 2.4.9-1-kitchen-sink
> 
> I know the thin client works because we test it with different server  
> before.
> 
> Can anyone offers some advices, please?

I had the same problem with PXE clients that I posted to this list last
week.  Several replies came back but didn't allow me to solve it.  In
the end it turned out to be a flaw in the install process (if you're
reading this, Eric?) that I finally stumbled on, broke through and now
have my system running with both PXE clients and floppy-boot clients.  I
don't mean I solved it in any clever way, I just chose my install
options differently :-)

Download the LTSP documentation, it contains many useful
trouble-shooting instructions.  Some things to look for:
1/ Look closely at all your most important services, dhcp, tftp, etc.
You may find some of them not running, I certainly did on my server.  
2/ Look at the IP address given to your NIC that connects to your
clients.  It should be IP: 192.168.0.254 mask: 255.255.255.0.  It must
have this address locked in, and eth0 must start when you boot your
server.  Mine kept failing and not finding its IP address.
3/ Look at your network devices status by running
'system-config-network' as superuser from a terminal, or select 'network
device control' from your 'system tools' menu.  Examine your NIC
properties and check that it stays activated for your clients.  Mine
kept dropping back to 'inactive' whenever I booted a client after my
manual configurations and restarting xinetd.  
4/ In the same dialogue box, check the 'hosts' associated with your NIC.
It should be populated with lots of ws001, ws002, etc.  Mine was
completely empty.

I tried installing 4.4.1 many times on my server without success on any
of the points above.  I also configured services manually after bootup.
I didn't know enough to do it thoroughly, so it never worked.  This was
a shock to me because when I used earlier versions of K12LTSP everything
just worked, even though I didn't know Linux at the time and certainly
didn't know how to configure networking services.     

This time around, I finally got my system working by choosing to install
ONLY the default settings.  That is, when I had installed 'everything'
or made extensive package selections, making sure to include LTSP, my
server would end up not working for my clients.  The only way I finally
cracked it was to choose the default 'LTSP' install option and not
change any other package choices that came with that (save substituting
KDE for Gnome).  Now, everything works just fine, phew.

If other people are having similar problems (?) maybe the installer
scripts need a little look, Eric (if you're reading)?

I HTH, Hung.  Post a followup if it does.

Gavin.   



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]