[K12OSN] Re: Sound demons :-(

JohnG jjjggg at hotmail.com
Thu May 4 18:01:54 UTC 2006

  ----- Original Message ----- 
  From: JohnG 
  To: k12osn at redhat.com 
  Sent: Wednesday, May 03, 2006 7:38 PM
  Subject: Sound demons :-(

  I'm trying to get sound working on a new K12LTSP install. It worked great on another server at 4.4.1 by only changing a couple of settings in the lts.conf file, but not on this one at either 4.4.1 or the latest 5.0 betas. It doesn't seem to have either the nasd or the esd deamons. I installed the rpm as specified at http://wiki.ltsp.org/twiki/bin/view/Ltsp/Sound#NASD_and_ESD but to no avail. There is no sound card on the server. Nasd or esd does not show up in a "ps aux" on either the server or client and a whereis can't find them either. What am I doing wrong? How do I fine these demon deamons and get them installed and running on the server (if that's my problem). Thanks in advance for any help.

  Oh, and 5.0 beta 4 and beta 5 are looking really good, thanks for all the great work!

I also checked the /opt/ltsp/i386/sbin directory, I found esd but no nasd. Running esd from root I get "no such card" and "device not found" errors. An echo of $AUDIOSERVER on the client return ws252.ltsp:0.0 and $LD_PRELOAD returns /lib/libaudooss.so.1.0. auinfo returns an error message that it can't connect to the audio server. The client I am using has sound when I hook it up to the other 4.4.1 server. I've tried every combination in lts.conf that I could think of, I've read the wikis, searched the archives, and googled. Any direction or debugging tips would be appreciated, this is so frustrating. 

I don't know if it would make a difference, but I can't throw a sound card into the server because it's PCI-X and all I have are PCI and ISA cards.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://listman.redhat.com/archives/k12osn/attachments/20060504/1f43071b/attachment.htm>

More information about the K12OSN mailing list