[K12OSN] usb printer troubleshooting

Barry R Cisna cisna-barry at wc235.k12.il.us
Sun May 14 21:09:11 UTC 2006

Hello All,

Hope  ya all had a good weekend.
I know this subject has been rehashed a zillion times ,but I'm stumped.
Thats why I m here:).

Would someone be able to give me a new angle on how to troubleshoot
local usb attached printers. All of a sudden now none of the usb
attached printers will work on any of the clients. Only thing i've
changed recently is I added the hplip package to all of our servers, but
I DO know these printers did work for a many weeks after installing this
package. The same client machines with the printers attached to them
will still print to our networked printers( HP 4100's). I can telnet to
each of these printers( locally attached), fine, but when i type some
stuff in a terminal and do the CTL-C or whatever it is to spit the page
out nothing happens.
If i use the cups admin web GUI the printers all show "accepting jobs".
I've reread the ltsp wiki on this and I m not sure what has happened to
kill the lpr or whatever to these printers.
If i do a modprobe printer at a terminal as user joe schmoe should i see
the locally attached printer, I'm guessing hp932c or similar? Not sure
on this? also the same for lsmod?
When the client machines bootup I am seeing the printer as a usblp0 or
something similar so my connections are good ( I think).
I'm thinking i should be able to simply do a :
telnet terminalipaddress 9100
then i see the connected to ^^^^
start typing some stuff in a terminal then press CTL-C( cant remember
second hotkey), and i should have text on the page? I'm probably missing
something here , in this combo:).
Ive always used the redhat-config-printer gui to add the printers to
these machines using the jetdirect protocol. I just last week tried just
the socket://ws005:9100 as well in the CUPS web GUI, still no joy.

K12LTSP v 4.1.1 

Any info/comments/laughs/i told you so's  appreciated.

Barry Cisna

More information about the K12OSN mailing list