[K12OSN] iMac booting intermittant

Joe Guenther jguenther at chinooksedge.ab.ca
Wed May 17 02:03:06 UTC 2006


Thanks for doing that testing for me.  I went right back to school after
supper (I live in the same town as the schools I service) and tested your
theory.  I was using an el-cheapo router/4 port switch (Gnet IP104) to
isolate this test set from the rest of my network.  I had changed the
network cable and it worked. On the next try that new cable did not work
again. At that point I paniced.  Now when I got back, I changed the
router/switch and both my iMac junkers booted immediately.  I am in fact
writing this on a bondi blue first generation iMAc with 32Mb RAM (took the
Hdd out too, so all it will do is netboot).  All works fantastic - at
least when it boots consistently.

Thanks for testing on your end to help isolate my problem.  Wow, what a
great community.  I never cease to marvel at how the whole open source
community holds together. One would never get that from an Oracle /
Microsoft / Sun corporation.  I will use this little incident as one of
the stories in my presentation on Friday. This K12LTSP community is
another one of the reasons to do Linux in school.
In fact we have moved to using the K12LTSP disro as the sole distro in our
division ... whether for a Samba server, an Apache web server or Tomcat
app server. We have a number of the CentOS installs running, and a number
of Fedora installs where the desktop is primary. Our thinking was - close
to redhat that we were familiar with - an excellent update repository
infrastructure - and the LTSP capability is nice to have in the background
when running a samba server. There is then nothing stopping us from simply
starting to boot thin clients besides the other desktops.. ... no extra
work.  So let me say a BIG thanks to you personally Eric.  We have never
met, but yet you have done so much for my tech career. (I started using
K12LTSP around version 3 when in Germany about  6 years ago) THANKS!!

Joe Guenther
Chinook's Edge School Division
Alberta, Canada

On Tue, May 16, 2006 5:58 pm, Eric Harrison said:
> Eric Harrison wrote:
>> Joe Guenther wrote:
>>> When trying to boot an iMac on the K12LTSP 5.0.0 beta5 with all
>>> updates,
>>> I somtimes get the
>>> /pci/mac-io/ethernet::-1,yaboot.conf: Unknown or corrupt filesystem
>>> Can't open config file
>>> Welcome to yaboot version 1.3.10
>>> Enter "help" to get some basic usage information
>>> boot: _
>>> Then it just sits there.  Occasionally it will boot properly.  This
>>> will
>>> be a REAL SHOWSTOPPER as I have been asked to demo this to Alberta zone
>>> 5 & 6 school division technology meeting.  I can boot an iBook by
>>> holding down the N key on boot. A big part of this demo is to show how
>>> to recycle old junkers ... we have a ton of old iMacs that run great
>>> IF/WHEN they boot.
>>> please help!
>>> Joe Guenther
>> I just tested on my junker iMac and I think it is an SELinux labeling
>> issue. Try turning off SELinux and see if the problem goes away:
>> 	echo 0 > /selinux/enforce
>> When I get the chance, I'll rebuild the package to fix this issue the
>> correct way...
> I got back to doing a little more testing. It is definitely NOT SELinux
> related, just happened to be pure luck that it worked earlier when I
> turned off enforcing mode.
> It appears that the problem was that I was using a cross-over cable to
> connect the iMac to the server. When I connected them both to a switch,
> the iMac boots every time.
> Any chance that you were using a cross-over cable as well? If you are
> using a managed switch, is Spanning Tree turned off?
> -Eric
> _______________________________________________
> K12OSN mailing list
> K12OSN at redhat.com
> https://www.redhat.com/mailman/listinfo/k12osn
> For more info see <http://www.k12os.org>
> !DSPAM:446a67f7231541940217895!

= = = = = = = = = = = = =
Lantech - Didsbury
Chinook's Edge School Div.

More information about the K12OSN mailing list