[K12OSN] tight vnc connection to ltsp client refused (111 error)

Trond Mæhlum trond at maehlum.net
Fri May 19 20:54:11 UTC 2006

Robert Arkiletian skrev:
> On 5/17/06, Dan Visentin <visentind at hdsb.ca> wrote:
>>  Howdy Folks,
>>  I've been experimenting with Fl_TeacherTool (brilliant Rob!) but cannot
>> monitor the LTSP clients.  I cannot even use the vncviewer to view 
>> clients.
>> In all cases I get a "connection refused (111)" error.  I've run 
>> vncpasswd
>> and copied files etc. as per instructions but to no avail.
> What version of k12ltsp are you using? k12ltsp 5.0 does not work with
> the monitor/control feature of fl_TT because there is no vnc X
> extension module compiled in the LBE. I developed fl_TT using k12ltsp
> 4.2.1EL. Although NO version of k12ltsp has the required module
> compiled in the LBE, out of sheer luck the required files when copied
> from the host OS seem to work in 4.2.1EL. That's why I labeled them
> experimental.

Robert and Dan,

This also works on K12LTSP 4.4.x. It seems that it will work on all 
installations of LTSP4.1 that I have tried. Sadly, it does not work on 
LTSP4.2 for now. I am one of many (I think) that will not let go of this 

I have tried it on the new Ubuntu and Skolelinux ltsp as well. I would 
suspect it to be much easier when you can chroot into the ltsp-tree and 
apt-get install vnc4server. Sadly I haven't been able to get it working 
there either. There's too many changes in ltsp, so the how-to doesn't 
apply to get the vncserver started at login on the terminal.

Trond Maehlum

> PS most lists prefer plain text instead of html

More information about the K12OSN mailing list