[K12OSN] tight vnc connection to ltsp client refused (111 error)

Robert Arkiletian robark at gmail.com
Tue May 23 00:00:20 UTC 2006

On 5/22/06, Jesse McDonnell <jessemcdonnell at comcast.net> wrote:
> > Try reseting the broadcast-monitor-control feature. It's under file
> > menu. Or just hit F9 (same thing).  See if that fixes things. Make
> > sure you are running fl_TT as root.
> Robert,
> Just tried resetting after I lose keyboard input and it closes and relaunches TeacherTool.

The reset (F9) does not kill TeacherTool. Only the processes running vnc.

>The password dialog box comes up when I select Control and accepts
keystrokes. This dialog box always accepts keyboard input

Yes. This is realvnc asking for the password  for vncviewer to allow
you to take "Control".

> I had keyboard input in Sylpheed (mail program) but then lost it after launching a terminal. Tried launching a terminal first and had input in the terminal, switched to Sylpheed, no input. Shutdown TeacherTool, killed off all instances of vnc (ps -ef | grep vnc) and on subsequent launches I had no keyboard input.

I don't have a k12ltsp 5.0 system at home I can test right now. So I
can't verify this behavior.

> It seems to be a random problem and I cannot see a pattern to when I have and when I don't have keyboard input. Do you think this may be an aberration peculiar to my setup? I don't need Control and Broadcast but I'm happy to do more tests if it will help make TeacherTool more robust.

Broadcast does not use the new vnc.so Eric made. I have verified
broadcast works with k12ltsp 5.0 at Linuxfest NW. If both Broadcast
and Control don't work for you I suspect you either have not installed
things correctly or your system has gremlins in it. :)

Robert Arkiletian
Fl_TeacherTool http://www3.telus.net/public/robark/Fl_TeacherTool/
C++ GUI tutorial http://www3.telus.net/public/robark/

More information about the K12OSN mailing list