[K12OSN] new LTSP 4.2 test packages with the VNC module built in

Jim McQuillan jam at mcquil.com
Thu May 25 19:50:28 UTC 2006

On Thu, May 25, 2006 3:11 pm, Eric Harrison wrote:
> Joe Guenther wrote:
>> Eric,
>> fine fine work!! The yum update worked perfectly. The Macromedia Flash
>> install
>> worked perfectly. The PC clients boot perfectly, the iMac clients boot
>> perfectly. Uum, this is getting very close to a production ready beta,
>> from the
>> things that I have tried and tested. Well done.
>> One little itty bitty fly in the ointment .... when one uses a different
>> IP
>> address for the server thatn192.168.0.254 (I use a 10.x.100.1) the LTSP
>> initialize script passes the that IP address on to the proper config
>> files -
>> etc/dhcpd-k12ltsp.conf, etc/exports, etc/hosts, opt/ltsp/etc/lts.conf
>> but it
>> does NOT pass that address on to the /opt/ltsp/ppc/etc/lts.conf.  The X
>> session
>> on an iMac client will not work until you go and change the ip address
>> in that
>> file.  I know about it and make the change during my initial install,
>> but there
>> may be users that use PC and then try a PPC client, only to not have it
>> work. Of
>> course this is all based on the change of the server IP address to use
>> something
>> other than the standard
> Yes indeed, that needs to be fixed. I should have it done tomorrow.
> Thanks for catching it ;-)
>> Just a little tip - but otherwise an incredible piece of work on the new
>> betas.
>> I have followed the beta process more closely this time as I was in the
>> middle
>> of a demo setup and wanted to demonstrate the new local mounting of USB
>> /
>> CD-rom.  The first couple of betas were a bit rough, but this is looking
>> finely
>> polished already.  Hat's off to you Eric!
>> Joe Guenther
> I now just need to figure out this stinking problem with the keyboard
> preferences crashing terminals!

X.org just released 7.1.  I'm thinking it would make sense to move from
6.9 to 7.1, and then see if the crashing still occurs.

The only problem is, it's a HUGE jump because 6.9 was the monolithic X
build, while 7.1 is the new modular build. I suspect we'll have about 30
package.def files to handle the entire build.

Fortunately, it will make individual updates to the Xservers much easier.

*Maybe* I'll have a chance this weekend to work on that stuff.

Jim McQuillan
jam at Ltsp.org

> -Eric
>> Eric Harrison wrote:
>>> The package rebuild has completed and has been tested.
>>> The server is pretty busy at the moment, the repositories may take
>>> longer than usual to rebuild. The fixed package should appear by 5:00pm
>>> PDT.
>>> -Eric
>>> Eric Harrison wrote:
>>>> Jesse McDonnell wrote:
>>>>> On Tue, 23 May 2006 22:09:29 -0700 (PDT)
>>>>> Eric Harrison <eharrison at mail.mesd.k12.or.us> wrote:
>>>>>> The good news:
>>>>>> I finally figured out a way to get the vnc X11 extension module to
>>>>>> build
>>>>>> consistently inside the LTSP build environment. I sent Jim the
>>>>>> patch,
>>>>>> hopefully the LTSP guys will find it useful as well.
>>>>>> I added the patched ltsp_i386 packages to the 5.0 beta repositories,
>>>>>> you should be able to run "yum update" in about 20 minutes or so to
>>>>>> install the new package.
>>>>> Saw this while drinking my first cup of coffee this morning and
>>>>> thought, let me try it. Did a yum *upgrade* instead of update and now
>>>>> my clients won't boot. Shouldn't be so eager before I wake up
>>>>> properly.
>>>>> The client fails at line 74 of /opt/ltsp/i386/etc/rc.sysinit with
>>>>> "modprobe - command not found" then fails to connect to the swap
>>>>> server, and finally with the message "stat of /dev/tty1 failed: no
>>>>> such file or directory" and "stat of /dev/tty2 failed: no such etc"
>>>>> If I turn off NBD swap it still fails with the "stat of /dev/tty1
>>>>> failed" message.
>>>>> Any pointers on how to fix this?
>>>>> Thanks,
>>>>> Jesse
>>>> Doh! A fine example of a brown-bag release :-(
>>>> I did test this before I uploaded it, I have no idea how my terminal
>>>> managed to boot...
>>>> I found the problem, but it takes a while to build new packages. In
>>>> the
>>>> meantime, you can revert to the old package. The 32bit repository has
>>>> been back-rev'd, the 64bit repository should be done in 10 minutes or
>>>> so...
>>>> 	rpm -e --nodeps ltsp_i386
>>>> 	yum clean all
>>>> 	yum install ltsp_i386
>>>> -Eric
> _______________________________________________
> K12OSN mailing list
> K12OSN at redhat.com
> https://www.redhat.com/mailman/listinfo/k12osn
> For more info see <http://www.k12os.org>

More information about the K12OSN mailing list