[K12OSN] tight vnc connection to ltsp client refused (111 error)

Dan Visentin visentind at hdsb.ca
Mon May 29 18:51:11 UTC 2006

Robert Arkiletian writes:
No password is required for the broadcasting. You only need to be
root. I'm going to try to guess your problem. You downloaded and
compiled fl_tt but did not run #make install. Hence, the
HOST_INFO_FILE is not copied to the correct place. Try running #make
install and see if that solves the problem. BTW if you install fl_tt
with yum, HOST_INFO_FILE gets copied to /etc/fl_teachertool/. If you
install from my source tarball HOST_INFO_FILE gets copied to
Let me know if this solves the problem.


Well Robert, I tried everything.  It all seems intact and I'm pretty sure that the problem is with vncreflector.
I've uninstalled everything using yum erase (vnc, vncreflector, fl_teachertool, vnc-ltsp-config, etc) and then did a yum install for everything that I uninstalled.  I also recompliled the sorce for v.32 and now have both v.21 and .32 on the system.  The
HOST_INFO_FILE is present and permissions are properly set.  I get the same errors in the log.  If I run vncserver -v 6 HOST_INFO_FILE, I get the following in the reflector.log file:

29/05/06 14:19:21 + Starting VNC Reflector 1.2.4
29/05/06 14:19:21 - Switched to the background mode
29/05/06 14:19:21   Our machine is little endian
29/05/06 14:19:21 : Looking for passwords in the file "passwd"
29/05/06 14:19:21 * No client password file, assuming no authentication
29/05/06 14:19:21 * Host password not specified, assuming no auth
29/05/06 14:19:21 + Connecting to localhost, port 5901
29/05/06 14:19:21 + Connection established
29/05/06 14:19:21 - Remote RFB Protocol version is 3.7
29/05/06 14:19:21 * Protocol sub-version does not match (ignoring)
29/05/06 14:19:21 : VNC authentication requested by host
29/05/06 14:19:21   Received random challenge
29/05/06 14:19:21   Sending DES-encrypted response
29/05/06 14:19:21 ! Authentication failed
29/05/06 14:19:21 * Closing connection to host
29/05/06 14:19:21 + Terminating

It would seem that there needs to be some authentication of some sort for vncreflector .  

installed software:
Fl_TeacherTool v.32

Dan Visentin
Head of Business/Computers/IT contact
M. M. Robinson H.S.
"As a computer, I find your faith in technology amusing."

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://listman.redhat.com/archives/k12osn/attachments/20060529/de2216f8/attachment.htm>

More information about the K12OSN mailing list