[K12OSN] Blender Issue

Eric Harrison eharrison at mail.mesd.k12.or.us
Tue May 30 17:11:28 UTC 2006

Steven Perks wrote:
> Hello,
> We did all this. I think there may be something wrong with GLX. As it
> worked
> perfectly before but after they installed some "Development" RPM's and some
> games and such it stopped working. I think one of those files may be
> corrupted or something happened to it as to why it is not loading. Is there
> a way we can reinstall GLX or fix it or confirm it does not work? As the
> date was also reset along with a few other things. Which sets me to believe
> something was changed.
> Thanks for you time!
> - Steve

This command will tell you the order that packages were installed (most
recent first):

	rpm -qa --last | less

Off the top of my head, I'd expect to find that either the X11 packages
(xorg-x11-*) or the Mesa packages (mesa-libGL*) were replaced.

Another useful option for rpm is to verify all of the installed packages:

	rpm -Va

That might give a hint as to what has been broken.


> On 5/29/06, Eric Harrison <eharrison at mail.mesd.k12.or.us> wrote:
>> On Mon, 29 May 2006, Steven Perks wrote:
>> > Hello There,
>> >
>> > We are running a computer club system and one of our members wants to
>> use
>> > blender. So we got it (Mr. C) and installed it and the nvidia drivers
>> and it
>> > worked fine on both the terminal and the clients. But when we came back
>> a
>> > few days after some kids installed xfrisk, and some more stuff and
>> suddenly
>> > it does not work anymore. The errors we get are
>> >
>> > Using Python version 2.4
>> > Could not find platform independent libraries <prefix>
>> > Could not find platform dependent libraries <exec_prefix>
>> > Consider setting $PYTHONHOME to <prefix>[:<exec_prefix>]
>> > 'import site' failed; use -v for traceback
>> > Xlib:  extension "GLX" missing on display "ws075.ltsp:0.0".
>> > ERROR: Unable to open Blender window
>> >
>> > It used to just be the GLX missing error but after we tried to fix
>> it we
>> got
>> > some more errors. Any advice or help will be GREATLY apprecitated.
>> Make sure you have glx enabled in /opt/ltsp/i386/etc/lts.conf
>>         X4_MODULE_01 = glx
>> -Eric

More information about the K12OSN mailing list