[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [K12OSN] Anyone tried smbldap installer with Centos 5 ??



Thanks for the pointers guys.

What I'll do is have a look though the packages that the installer script uses for CentOS 4.4 and then try to find the relevent packages either via one of the 7 CD's or Yum etc.

When I'm done I'll let you guys know so people don't have to reinvent the wheel :-)

Brian

John Lucas wrote:
If I were deploying on a production system, I would pre-install the needed packages from the most suitable yum repositories (i.e. dag's "el5" if missing from base and extras etc.) and then run the smbldap-installer script *after* installing those packages in order to ensure more straightforward updates in future. The right place to fix this is to update the scripts, but I am not a perl programmer.

I think I'll peruse my yum log and make a list ...

On Wednesday 25 April 2007 13:47, Tom Astle wrote:
These same issues cause the CentOS 4.4 not to work too.

John Lucas wrote:
On Wednesday 25 April 2007 09:02, Brian Chivers wrote:
I'm about to start installing several new servers ready for the summer
swap and wondered if anyone had tried the smbldap installer script with
Centos 5 and if so would share any "gotchas" :-)
Your query prompted me to try it out. I ran smbldap-installer (v3.1) on a
CentOS-5 virtual machine (VMware Server v1.0.2) and selected "centos44"
as the installation target host. I was able to get SMB-LDAP installed,
configured and running *but* the installation script does not work out of
the box. I ran into the following problems (and workarounds):

1. Vanilla CentOS-5 does not define the "dag" repository.
	Fix: That is Dag Wieers repository: http://dag.wieers.com/

2. Repository has been renamed "rpmforge"
	Fix: In /etc/yum.repos.d/rpmforge.repo change [rpmforge] to [dag]

3. Still can't get several Perl modules due to version mismatches
	Fix: use yum to install packages without reference to version numbers

4. The smbldap-tools didn't get installed. Manual installation collides
with perl-ldap module.
	Fix: remove perl-ldap modle with yum. Use yum to get right perl-ldap and
then install smbldap-tools.

The installer script used a hodge-podge of packages from the "dag"
repository (several old Fedora packages for instance). Dag seems to have
a suitable "el5" branch that takes care of that, but the scripts need to
be updated.

As clumsy as this exercise was, it is far simpler than rolling your own
and it seems to work if you can get to the end of the configuration step.
Those more familiar with "smbldap-installer" may have a more elegant way
to fix it.
_______________________________________________
K12OSN mailing list
K12OSN redhat com
https://www.redhat.com/mailman/listinfo/k12osn
For more info see <http://www.k12os.org>



------------------------------------------------------------------------------------------------
   The views expressed here are my own and not necessarily

the views of Portsmouth College
[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]