[K12OSN] OOo not defaulting to MS formats in version 6

Nils Breunese nils at breun.nl
Fri Aug 24 13:24:51 UTC 2007

I wrote:

> Eric Harrison wrote:
>> Petre Scheie wrote:
>>> Eric Harrison wrote:
>>>> Petre Scheie wrote:
>>>>> I just noticed that OOo is not defaulting to MS  
>>>>> formats--.doc, .xls,
>>>>> .ppt--when saving documents.  I see the
>>>>> /opt/ltsp/templates/k12linux/openoffice-ms-format-defaults.sh  
>>>>> file, and
>>>>> I ran it as root, but it didn't change anything for existing users
>>>>> (didn't try creating a new user afterward).  Didn't there use  
>>>>> to be an
>>>>> icon on root's desktop for running this?  Or was it run by default
>>>>> during installation?  Should the script still work?
>>>>> Petre
>>>> Running /opt/ltsp/templates/k12linux/openoffice-ms-format- 
>>>> defaults.sh
>>>> should reset the defaults back to the MS formats.
>>>> If a user changes their personal settings, it will over-ride the
>>>> defaults. You might try nuking a user's ~/.openoffice* directory  
>>>> so that
>>>> they pick back up the default settings.
>>> Removing the users ~/.openoffice* does fix it.  Did the
>>> openoffice-ms-format-defaults.sh previously run automatically or  
>>> have I
>>> just forgotten that I ran it manually in the past?
>>> Thanks Eric.
>>> Petre
>> The script runs automatically at install time. Updates can over-write
>> the changes.
>> As far as I know, a user's setting will only over-ride the  
>> defaults if
>> the user manually changes their settings.
> I have a fresh K12LTSP 5EL install and my test user defaults to  
> saving as .odt. I did run a 'yum update' after the installation  
> which installed an OpenOffice.org update. Could the update have  
> caused the defaults to reset, or did the script maybe not run at  
> install time?
> I ran /opt/ltsp/templates/k12linux/openoffice-ms-format-defaults.sh  
> again and nuked the test user's .openoffice.org2.0 directory, but  
> Writer still defaults to saving as .odt. Is this a known issue?

I believe the /opt/ltsp/templates/k12linux/openoffice-ms-format- 
defaults.sh script has an error in the 64-bit version. It tries to  
access files in /usr/lib, while they are in /usr/lib64. I don't know  
who wrote or maintains this script, but could this be fixed for the  
64-bit version of K12LTSP (5EL)?

Nils Breunese.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: PGP.sig
Type: application/pgp-signature
Size: 186 bytes
Desc: Dit deel van het bericht is digitaal ondertekend
URL: <http://listman.redhat.com/archives/k12osn/attachments/20070824/86ddc965/attachment.sig>

More information about the K12OSN mailing list