[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [K12OSN] no response from dhcp server (eBox 2300SX)



Hi Barry :-)

i'm using FC6 with ltsp 4.2.
we have this server running just fine (for years) with different kinds
of PC terminals
getting IPs from the DHCP daemon. from eth1. i don't understand why i
should bind
the DHCPD to eth0 ?

i have this setup (working)
eth0 - i get internet from ,
eth1 - the terminals ,
eth2 - wireless ,
eht3 - some other terminals

only the eBox is not getting an ip after it boots.
(the kernel is downloaded into it and boots fine)

Listening on LPF/eth1/00:0e:2e:6a:f5:bd/WORKSTATIONS-A
Sending on   LPF/eth1/00:0e:2e:6a:f5:bd/WORKSTATIONS-A
Sending on   Socket/fallback/fallback-net
DHCPDISCOVER from 00:1b:eb:02:00:91 via eth1
DHCPOFFER on 192.168.10.253 to 00:1b:eb:02:00:91 via eth1
DHCPREQUEST for 192.168.10.253 (192.168.10.254) from 00:1b:eb:02:00:91 via eth1
DHCPACK on 192.168.10.253 to 00:1b:eb:02:00:91 via eth1

kernel loads fine and then it asks for an IP again with the dhcp client
and dies after not getting any IP from the server.

DHCPDISCOVER from 00:00:60:00:00:01 via eth1
DHCPOFFER on 192.168.10.252 to 00:00:60:00:00:01 via eth1
DHCPDISCOVER from 00:00:60:00:00:01 via eth1
DHCPOFFER on 192.168.10.252 to 00:00:60:00:00:01 via eth1
DHCPDISCOVER from 00:00:60:00:00:01 via eth1
DHCPOFFER on 192.168.10.252 to 00:00:60:00:00:01 via eth1
DHCPDISCOVER from 00:00:60:00:00:01 via eth1


mean while, i read that i should be using the r6040 module
with a special patch for this problem. (well... now i have it)

but i find myself unable to understand how do compile and add it
to the current kernel i use - 2.6.20.

i tried to follow the LBE instructions for version 4.2 but it's so
broken that i can't
finish all the suggested steps in the documentation :-(

if anyone has a working LBE and he/she could compile the r6040 module
and send it over i'll be sending positive energy vibes back to him/her
whole year round !!!

happy new year !
:-)


On 22/12/2007, Barry Cisna <brcisna eazylivin net> wrote:
> Nadav,
>
> You didn't say what distro you are using for your k12ltsp server,,,,but
> your dhcp server is running on the wrong nic on your server for sure. Your
> " DHCPOFFER, DHCPDISCOVER" should be on eth0 NOT eth1 as yours is showing.
> try reversing your cat5 cables into your switch off of the back of your
> server and your ebox may or may not boot. This is not a  correct
> fix,,though. Your dhcp server is dishing dhcp on the wrong nic( for
> k12ltsp specs at least).
> As said, you SHOULD be seeing your dhcp requests on eth0.
> Ebox 2300's will boot with no probs..providing you enabled pxe boot in the
> bios of EBOX 2300( this is not default)
> Hope this helps.
>
> Take Care,
> Barry Cisna
>
> _______________________________________________
> K12OSN mailing list
> K12OSN redhat com
> https://www.redhat.com/mailman/listinfo/k12osn
> For more info see <http://www.k12os.org>
>


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]