[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [K12OSN] AD Integration: Not able to login with domain account



Hi Amy,

Another thing you might try is logging in to "single user mode" and
editing the file you changed from there. When you boot your server you
should have about three seconds when the boot menu comes up to hit "e"
for edit mode (if I remember correctly) then you can use the arrow
keys to naviage to the line which has boot info about your kernel
(usually the second line down). Hit "e" to edit this line and add this
at the end "single" (leave off the qoutes). Then hit enter, that
should return you to the previous screen. Hit "b" to tell the Grub
boot-loader to load. Hopefully the computer will boot into a command
line with you as root.

Here's another description taken from a site I found via google:

"Using GRUB, you can manually edit the proposed menu entry at boot
time. To do so, when GRUB is presenting the menu list (you might need
to press ESC first), follow those instructions:

   * use the arrows to select the boot entry you want to modify.
   * press e to edit the entry
   * use the arrows to go to kernel line
   * press e to edit this entry
   * at the end of the line add the word single
   * press ESC to go back to the parent menu
   * press b to boot this kernel

The kernel should be booting as usual (except for the graphical splash
screen you might be used to), and you will finally get a root prompt
(sh#)."

Here's some google keywords to try


fedora grub single user mode

Hope this helps.

John

On 7/3/07, Amy Contreras <acontreras walkerville k12 mi us> wrote:


I've installed K12LTSP 5 and I am currently trying to integrate Active
Directory.  For the most part I've been following the K12LTSP Wiki on
ADIntigration
http://www.k12ltsp.org/mediawiki/index.php/Technical:ADIntegration.
 I was able to join the domain successfully and then made the necessary
changes to allow domain account users to login.  Afterward I was not able to
successfully login with the user accounts that I tried.  I did set the
default domain and restarted winbind.  I tried to test several accounts by
using the # su - "user" command and it appeared to acknowledge the user
accounts but didn't like the passwords.  Now this is where I get myself in
real trouble.  I seen that someone else got it working properly by changing
the default login manager from GDM to KDM by editing /etc/sysconfig/desktop
and adding DISPLAYMANAGER="KDE".  Big mistake.  Now I'm basically stuck
because I'm not able to login as root and when I login with my local account
I'm not able to make any changes because I somehow lack the proper
permissions.  I tried using sudo to access the desktop file among others but
that didn't work either.  I've done a google search and searched the
archives but haven't found anything yet.  Please help!

Amy Contreras
_______________________________________________
K12OSN mailing list
K12OSN redhat com
https://www.redhat.com/mailman/listinfo/k12osn
For more info see <http://www.k12os.org>



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]