[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [K12OSN] K12LTSP 5 EL



You may have solved this problem by now--sorry, I'm a little behind in my mail--but I recall a similar problem a year or so ago. It was produced by conflicts between two different repos, something like freshrpms and livna. They both had IceWM packages but one's had a dependency that that the other's didn't but yum was confused by that clash and was looking for the dependency in the wrong repo. Turning off one of the repos (temporarily) avoided the problem (there's a commandline option for ignoring a repo that I can never remember). Check the list archives.

Peter

Nils Breunese wrote:
Rob Owens wrote:

On Mon, Jul 02, 2007 at 04:24:42PM +0200, Nils Breunese wrote:
Rob Owens wrote:

Eric has the rpmforge repo disabled by default.  You can edit
k12ltsp-rpmforge.repo to include "enabled=1"

Ah, I see now. I'm probably just too used to installing the rpmforge-
release package myself.

After removing the rpmforge-release package and just enabling the
repo in k12ltsp-rpmforge.repo I ran yum update, but this failed with:

--> Processing Dependency: libImlib.so.1()(64bit) for package: icewm
--> Finished Dependency Resolution
Error: Missing Dependency: libImlib.so.1()(64bit) is needed by
package icewm

We don't use IceWM, but it came with the default install settings. Is
this something to report to rpmforge? I know I can just exclude or
remove the icewm package.

I don't know what's causing that.  I haven't seen that error on my
server.  Maybe it's a conflict resulting from your having both
rpmforge.repo and k12ltsp-rpmforge.repo enabled previously?  When I was
having weird yum trouble, Eric suggested a "yum clean all" and that
fixed it.  Maybe give that a try.

I already tried that, but the problem still occurs. The currently installed package is icewm-1.2.28-1.k12ltsp.6.0.0 and yum tries to upgrade to icewm-1.2.30-1.el5.rf, but fails because of the dependency error.

The dependency is provided by imlib-1.9.13-30.fc6. rpmforge has 1.9.13-1.el5.rf in the repository. The problem is probably that the rpmforge icewm package needs rpmforge's imlib package and that the k12ltsp icewm package needs the fc6 imlib package.

Has anyone else run a succesful yum update on K12LTSP 5EL while having icewm installed and rpmforge enabled? Are you running 1.2.28 from K12LTSP or 1.2.30 from rpmforge?

I could force rpmforge's imlib onto my system and upgrade to rpmforge's icewm package, but then yum update would probably give me a similar dependency problem with imlib.

I guess I'll just remove the icewm package, since we're not using IceWM anyway.

Nils Breunese.



------------------------------------------------------------------------

_______________________________________________
K12OSN mailing list
K12OSN redhat com
https://www.redhat.com/mailman/listinfo/k12osn
For more info see <http://www.k12os.org>


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]