[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [K12OSN] Getting eMacs to boot.



Jim Kronebusch wrote
> > Is there a way to set up SCREEN_02 so I can alt-f2 or ctrl-alt-f2 to
> > a shell window while startx is running in the other one? Or is there a way
> > of firing off startx so it tries once and exits?  I'm not sure where
> > I would look to see if anything useful is being logged. Further
> > suggestions would be appreciated.
>
> In lts.conf set:
> SCREEN_01=startx
> SCREEN_02=shell
>
> Then you can ctrl-alt-f2 to get a shell while the default screen_01 is starting x.

This works, but I also need to add:

  2:3:respawn:/bin/startsess tty2 /bin/bash --login

to the inittab file.

> > On the pre-slot loading front, I made some accidental progress. I
> > tried doing a vanilla install of Yellow Dog and it failed on the second
> > CD, forcing a reboot. Fortunately I had the iMac on the ltsp portion of
> > the network and it automatically found the server and booted up!
> >
> > Evidently yaboot was installed on the imac and that is all it needed
> > to get on the network and then boot from the server. So my question is,
> > how do I go about installing just the basic yaboot software on those
> > old iMacs without going through the whole Yellow Dog install CD 1?
>
> If you are describing the first vintage Bondi Blue (looks like an ugly green to me) iMac
> G3 then there is nothing needed to boot the LTSP server other than holding down the "N"
> key on startup to trigger booting from the server.  Or just pull the hard drive out of
> the machines and since they cannot find a local boot device they will automatically poll
> the network.  You can also hard code booting off the server via firmware if you like.

I was making a bad assumption here. I thought since I couldn't
net-install mac OS on these older machines it implied I could not
netboot. I was wrong. They work just fine by booting with the "N"
key and the default server configuration.

How do I hard code the booting via firmware?

> Take a look at the included XF86Config.indigo file for reference.

I tried the .indigo config early on with no success, but I tried it
again and now it works just fine with a couple of flavors of
slot-loading iMacs.

My newest pre-intel white emacs still don't work. This appears to be
a more serious problem because I can't even get it to come up with
a shell window. I'm not concerned, as it will be a year or more before
I will want to use those computers as clients.

To sum up: most of my current concerns are resolved. I would like to know
how to select netboot via the firmware. Newer eMacs don't work, but that
problem can wait.

Thanks for all of the help!

--
Jon Harder
Mountain Lake Public Schools


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]