[K12OSN] Getting eMacs to boot.

Jon Harder linuxk12 at mountainlake.k12.mn.us
Wed Jun 13 17:56:31 UTC 2007

Hi. I'm the technology coordinator at the Mountain Lake public school.
I've been using Linux servers for years. This summer I decided it was
time to convert an aging lab and two classroom mini-labs to ltsp.

I have never tried ltsp software until a week ago. It loaded right
up and it was trivial to get a PXE-based net boot PC and floopy-boot
PC to come right up. Adding ldap authentication and the remote directories
of 500+ users was only delayed a day because of a typo in the ldap
configuration. Even allowing for the fat-finger typing, that all worked
out much slicker than I anticipating.

I'm stuck on getting a newish eMac to net boot. The server log shows
that it is checking in for its DHCP assignment, and the client screen
starts scrolling. Just before it goes all black it says (if this is

  setup_arch: enter
  setup_arch: bootmem
  ardn: exit
  openpic: enter
  openpic: timer
  openpic: external
  openpic: suprious
  openpic: exit

then the screen is blanked, a line flashes in the middle that may
include the word "welcome" but it is really too fast to decipher.

I would appreciate any pointers on how to get the eMac to boot. I
suspect the answer will also allow me to boot the very oldest
slot-loading iMacs. Then I'll be back to see how to hd-boot the
older pre-slot loading iMacs. The success of my transition to ltsp
depends on reusing these old macs ...

Jon Harder
Mountain Lake, MN

More information about the K12OSN mailing list