[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [K12OSN] squid error





On 6/10/07, Barry Cisna <brcisna eazylivin net> wrote:
Jim,

The best way to get up and running with Squid is to simply start Squid
then providing you have DansGuardian installed is start DG after you have
started Squid. Also install Webmin. It has an easy to use interface for
displaying DG logs within Webmin.(You have to download the plugin for DG
to Webmin, as it is not a standard module with Webmin)
You shouldn't have to do any configing with Squid or DG ,providing you
installed the rpm's for each that comes with K12LTSP.If you are getting
the squid error, do an ' rpm -e squid ' in a terminal to uninstall squid.
Then go to you software updater on the start menu and reinstall Squid. You
shouldn't have to do anything to get Squid to start is the bottom line.
SquidGaurd on the other hand you do have to do some configing,if you are
really wanting to use SquidGuard along with Squid. Read the readme that is
supplied with SquidGuard if this is the case. It is kinda tricky to get
working but works fine once you figure what settings you want. DG is much
easier for beginning to make work from the get go.

hope this helps.

Take care,

Barry Cisna

I've tried installing and reinstalling various squid versions using the add/remove software tool (always uninstalling first).  The install seems to complete successfully but i stll get the "No running copy" error in Services.  I've reinstalled K12LTSP v 5 on a test server and stll get the same error.

I tried starting squid with "/sbin/service squid start" but it failed:

init_cache_dir /var/spool/squid... /etc/init.d/squid: line 54:  2606 Aborted              $SQUID -z -F -D >>/var/log/squid/squid.out 2>&1
Starting squid: /etc/init.d/squid: line 53:  2607 Aborted                 $SQUID $SQUID_OPTS >>/var/log/squid/squid.out 2>&1
                                                           [FAILED]

I'm at a loss for what to do next.  I've installed K12LTSP v.5 with the same CDs I used on the production server.  I have been able to successfully install and use squid, DansGuardian, and webmin with the DG module on a test install of FC 7, but I used RPMs from other sources than the DVD or the FC 7 repositories.  I'm planning on upgrading to the CentOS version of LTSP when it becomes available... perhaps I should just wait it out?

Jim Anderson


_______________________________________________
K12OSN mailing list
K12OSN redhat com
https://www.redhat.com/mailman/listinfo/k12osn
For more info see < http://www.k12os.org>


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]