[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[K12OSN] smbldap very slow - getent not showing ldap users and groups



I have a problem that when I run getent passwd or getent group it only
shows the system users not the ldap users. It gets as far as sabayon
(the last user and last group) then hangs for a few minutes before
exiting without showing ldap users.
Is this serious? How can I fix it?

I can add a group.
# smbldap-groupadd -g 528 newentrant
but it takes a long time to execute the command. It hangs for several minutes.

I thought ncsd might have something to do with it so I turned off. It
made no difference.

I can smbldap-usermod -G <existing group> <username>
to add a user to an existing group. This is quick.
So is usershow and groupshow.

When I tried to add a user using useradd-bulk
I got this error.

/usr/sbin/smbldap-useradd: unknown group 525
The errors were encountered during processing:
smbldap-useradd error for sample: 1536.

But as you can see group 525 does exist:

[root k12ltsp1 smbldap-installer]# smbldap-groupshow students
dn: cn=students,ou=Groups,dc=harekrishna,dc=school,dc=nz
objectClass: posixGroup,sambaGroupMapping
cn: students
gidNumber: 525
sambaSID: S-1-5-21-3526296067-2545244986-3525108052-2051
sambaGroupType: 2
displayName: students
memberUid: aruni,vimala,krsnendu

Any help would be appreciated. I need to get all my students up and
running on Monday for an online test required by the local Ministry of
Education.

Krsnendu dasa


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]