[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [K12OSN] server won;t start



I restored using a ldif file that I know is good. That didn't seem to
help so I reinstalled using smbldap all then rebooted. While rebooting
it always hangs at the following stages.
NFS quotas
NFS mountd

What shall I do now?

On 16/03/07, Krsnendu dasa <krsnendu108 gmail com> wrote:
I reinstalled smbldap and the db config file was recreated. It seems
that when you delete the contents of /var/lib/ldap it deletes the db
config file and slapadd doesn't recreate it. So I made a copy of it to
copy back if I need to reset the system again.

I'll try restoring up with an older backup and if all else fails I
will try starting fresh and building my userbase again. I just need to
make sure that the numbers match the users. I only have my staff
members on at the moment (less than 10 users to sort out). The
students can be added later when things are working.

On 16/03/07, David Hopkins <dahopkins429 gmail com> wrote:
> Off-list,  if you need an DB_CONFIG file, i can send mine to you tomorrow.
>
> Dave ...
>
>
> On 3/15/07, Krsnendu dasa < krsnendu108 gmail com> wrote:
> > ldap restarts okay with this message.
> >
> > [root k12ltsp1 ~]# service ldap restart
> > Stopping slapd:
>  [  OK  ]
> > Checking configuration files for slapd:  bdb_db_open: Warning - No
> > DB_CONFIG file found in directory /var/lib/ldap: (2)
> > Expect poor performance for suffix dc=harekrishna,dc=school,dc=nz.
> > config file testing succeeded
> >
>  [  OK  ]
> > Starting slapd:
>  [  OK  ]
> > [root k12ltsp1 ~]#
> >
> >
> > I did interactive booting to fix ldap one reboot back. The restore
> > script didn't work for me so I manually cleared out the ldap database
> > and did slapadd. Maybe I have to do it again?
> >
> > On 16/03/07, Krsnendu dasa <krsnendu108 gmail com> wrote:
> > > It made it to the log in screen. I can log in as root. When I log out
> > > it takes a long time to come to the login screen again. I am still
> > > waiting. I want to see if I can log in as a regular user.
> > > On the clients dhcpd gives out the ip address but tftp only shows dots
> > > and times out.
> > >
> > > On 16/03/07, David Hopkins < dahopkins429 gmail com> wrote:
> > > > It sounds like you are having authentication issues with ldap.
> > > >
> > > > A couple of months ago there were some other very good suggestions on
> > > > getting past this via booting to run level 3 (or 1, can't remember).
> But at
> > > > any rate, try and sort out the ldap issues.  Does ldap start?
> > > > /etc/init.d/ldap restart
> > > >
> > > > If it is failing, then that is the issue.
> > > >
> > > >
> > > > On 3/15/07, Krsnendu dasa < krsnendu108 gmail com> wrote:
> > > > >
> > > > > The computer is getting stuck at nfs quotas stage. I am using
> smbldap.
> > > > > dhcpd doesn't start either.
> > > > > Can anyone help?


On 16/03/07, David Hopkins <dahopkins429 gmail com> wrote:
> Actually, try and create the DB_CONFIG file.  I am not  sure where this is
> initially created, but perhaps the Openldap example would be a good start?
>
> http://sapiens.wustl.edu/~sysmain/info/openldap/openldap_configure_bdb.html
>
> Sincerely,
> Dave Hopkins
>
>
>
>  On 3/15/07, Krsnendu dasa <krsnendu108 gmail com> wrote:
> > ldap restarts okay with this message.
> >
> > [root k12ltsp1 ~]# service ldap restart
> > Stopping slapd:
>  [  OK  ]
> > Checking configuration files for slapd:  bdb_db_open: Warning - No
> > DB_CONFIG file found in directory /var/lib/ldap: (2)
> > Expect poor performance for suffix dc=harekrishna,dc=school,dc=nz.
> > config file testing succeeded
> >
>  [  OK  ]
> > Starting slapd:
>  [  OK  ]
> > [root k12ltsp1 ~]#
> >
> >
> > I did interactive booting to fix ldap one reboot back. The restore
> > script didn't work for me so I manually cleared out the ldap database
> > and did slapadd. Maybe I have to do it again?
> >
> > On 16/03/07, Krsnendu dasa <krsnendu108 gmail com> wrote:
> > > It made it to the log in screen. I can log in as root. When I log out
> > > it takes a long time to come to the login screen again. I am still
> > > waiting. I want to see if I can log in as a regular user.
> > > On the clients dhcpd gives out the ip address but tftp only shows dots
> > > and times out.
> > >
> > > On 16/03/07, David Hopkins <dahopkins429 gmail com> wrote:
> > > > It sounds like you are having authentication issues with ldap.
> > > >
> > > > A couple of months ago there were some other very good suggestions on
> > > > getting past this via booting to run level 3 (or 1, can't remember).
> But at
> > > > any rate, try and sort out the ldap issues.  Does ldap start?
> > > > /etc/init.d/ldap restart
> > > >
> > > > If it is failing, then that is the issue.
> > > >
> > > >
> > > > On 3/15/07, Krsnendu dasa <krsnendu108 gmail com > wrote:
> > > > >
> > > > > The computer is getting stuck at nfs quotas stage. I am using
> smbldap.
> > > > > dhcpd doesn't start either.
> > > > > Can anyone help?
> > > > >
> > > > > _______________________________________________
> > > > > K12OSN mailing list
> > > > > K12OSN redhat com
> > > > > https://www.redhat.com/mailman/listinfo/k12osn
> > > > > For more info see <http://www.k12os.org>
> > > > >
> > > >
> > > >
> > > > _______________________________________________
> > > > K12OSN mailing list
> > > > K12OSN redhat com
> > > > https://www.redhat.com/mailman/listinfo/k12osn
> > > > For more info see <http://www.k12os.org>
> > > >
> > >
> >
> > _______________________________________________
> > K12OSN mailing list
> > K12OSN redhat com
> > https://www.redhat.com/mailman/listinfo/k12osn
> > For more info see <http://www.k12os.org>
> >
>
>
> _______________________________________________
> K12OSN mailing list
> K12OSN redhat com
> https://www.redhat.com/mailman/listinfo/k12osn
> For more info see <http://www.k12os.org>
>



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]