[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [K12OSN] Full system file access from terminals??



xmechanic wrote:
Hi,
I run a small computer service that services a local K-12 school district and I've been experimenting with K12OS with the hopes of making a valid presentation to the school to get them interested in moving to a thin client type environment. I first downloaded version 6.0 and installed it on a test machine here with dual NICs, and no matter how I configured it, I could never get my client(s) to boot. The server would hand off the IP address to the terminal from DHCP, and then it would hang while trying to load the kernel. I checked my /etc/dhcpd.conf, ltsp.conf, /etc/exports, and everything else I could think of, to no avail. I finally started checking forums and found that several people have had client boot problems with 6.0. So I downloaded and installed Ver. 5.0 and copied over the sample /etc/dhcpd.conf file and voila! The terminal(s) boot perfectly. Now for problem "B". It seems the terminal users have access to the servers complete file system! According to my /etc/exports file, this shouldn't be so. I think somehow the terminal is loading the server system rather than the filesystem exported from /opt/ltsp/i386. What tipped me off was the fact that when I log off a user on the terminal, I get an x-server error on the server screen and have to hit Ctrl-alt-F7 to get my screen back. Anyone have any ideas? I really like this system now that the terminals actually boot from it. A 733mhz. Dell desktop with 256mb of RAM takes about 35 seconds to go from power off to a login screen and another 12 seconds to the desktop. That would certainly be quicker with a real boot ROM instead of a boot floppy. If I can get the exports thing worked out and get it to boot from the correct filesystem, I'll be a happy camper. Any and all input greatly appreciated. I've been about 4 days on this now and I'm running out of ideas. :-p

Dave Land
Land Computer Service

Not sure why version 6 wouldn't work when version 5 does. Did you try turning off selinux? That has caused problems in the past.

As for the users having access to the full file system on the server, that is the way it's supposed to work; it is not a chrooted environment that the users log into. A kernel and an X server are loaded on the client, but then pointed at the display manager, gdm by default, on the server via xdmcp. So, users are logging into the server similar to if they were telnetting or ssh-ing in, except with a graphical interface. Once logged in, users are 'on' the server.

Petre


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]