[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [K12OSN] smbldap user creation home directory problems

Regarding your ".dmrc file..." error message, I found the following
information in my notes from this list from fall 2006.  I think I had
this problem then, too, and I think this solution worked for me.  Of
course, YMMV.  :)

Try modifying /etc/gdm/custom.conf and adding the following line under
the [security] section:

David Whitmer
Director of Media & Technology
Calvary Schools of Holland (Michigan)
web: www.calvaryschoolsholland.org
email: thewhitmers gmail com

On 5/7/07, Krsnendu dasa <krsnendu108 gmail com> wrote:
I have been using smbldap-useradd bulk for add all my users without
any problem till now.
I used the same syntax I alway used.

When he tried to log in he got the message that there is no home directory.
So I ran the command again making sure to use the -m option.
After running this command it gave a warning message like "the id
number of the /home/user directory does not match the user id of this

Now when he tries to log in he gets the "User's $HOME/.dmrc file is
being ignored. This prevents the default session and language from
being saved. File should be owned by user and have 644 permissions.
Users $HOME directory must be owned by the user and not writable by
other users."

I tried changing the user number of the user, but I still can't log in
properly. I get errors saying something like gconf cannot write.
I tried changing the ownership of /home/user too but that also didn't
seem to help.

I have been running two ltsp servers in parallel. Perhaps this is
causing the problem. I have shut down the other server now, but the
problem remains.

Any clues what I should do now?

Krsnendu dasa

K12OSN mailing list
K12OSN redhat com
For more info see <http://www.k12os.org>

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]