[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [K12OSN] can't get sound on Dell GX1's using K12LTSP v 5



I found the below post when trying to get sound working on my GX1. 

the following line worked for me:

## Dell GX1
[00:C0:4f:13:5e:2c]
	SMODULE_01="cs4232 io=0x534 irq=5 dma=1"

however, more importantly, this is the missing link - in later versions
of K12LTSP (I'm on ver. 6), the sound card is no longer listed
in /opt/ltsp/i386/etc/audiolist

you need to paste this line in the Cirrus Logic section

1013:6006       cs4232          #CS4232 CrystalClear PCI Audio Interface

and if you are using the alsa mod, this line in audiolist-alsa

1013:6006       snd-cs4232          #CS4232 CrystalClear PCI Audio Interface

Hope this helps someone.

regards,
William


[K12OSN] can't get sound on Dell GX1's using K12LTSP v 5

________________________________________________________________________
      * From: Jim Anderson <jand689 yahoo com>
      * To: k12osn redhat com
      * Subject: [K12OSN] can't get sound on Dell GX1's using K12LTSP v
        5
      * Date: Wed, 4 Apr 2007 16:08:42 -0700 (PDT)

________________________________________________________________________
I've been trying to get sound without success.  I have a room full of
Dell GX1 computers.  According to Dell's specs, and as confirmed with a
Knoppix live CD, the sound chip is a CS4236.  I have changed my lts.conf
to reflect this.  here's the relevant section:

# enable sound by default
        SOUND              = Y
        # choose either esd or nasd to be the default (esd only on
x86_64)
    SOUND_DAEMON       = "esd"
    # SOUND_DAEMON     = "nasd"

        # default sound volume
        VOLUME             = 75

        ### For ISA sound cards, you have to specify the module to use:
        SMODULE_01       = "snd-cs4236"
# io=0x220 irq=5 dma=1"

I don't know the io and irq for the card, which is supposedly PnP.

The error the clients get at boot is:
/dev/dsp: no such file or directory

There is no /dev/dsp directory.  I have various sound apps installed but
obviously they are not working.
Help!

Jim Anderson,
The Cornerstone Residence,
Safe Harbors of the Hudson





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]