[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [K12OSN] SDL - unable to initialize video errors

> Carl Keil wrote:
>> These games worked fine up until a few days ago. Perhaps I yum installed
>> something in my sleep that's causing problems. I tried rolling back the
>> kernel to no avail. This happens for all the users I've tried on 3
>> different clients with three different monitor types.
> su -
> less /var/log/yum.log
> --
> Dan Young <dyoung mesd k12 or us>
> Multnomah ESD - Technology Services
> 503-257-1562

Thank you so much for that very helpful one-liner.

OK, I'm an idiot.  That shows that SDL itself was updated on May 15th,
which fits the timeframe perfectly.

(from the log)
May 15 06:22:23 Updated: SDL.i386 1.2.9-6

So, what's the best solution?  Do I need to yum remove that and install an
older one from RPM?  Is there a "yum way" to do that?  Should I file a bug
with the SDL people?  (Whoever they are?)  Man, it would be really cool if
there was a "yum downgrade foopackage" command.

I'll start googling now, but I'd appreciate any suggestions.  I always
feel like there's a million ways to troubleshoot linux problems, but no
clear "best" method.

Thanks again.

Viva la Linux libre and K12ltsp.


PS - Is it risky to turn nightly Yum off on a production box?  It seems
risky to leave it on, because stuff like this happens, but is it analogous
to not running update on a windows box, in that I'm leaving myself open to
security vulnerabilities?

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]