[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [K12OSN] BUILT-IN NIC - solved (sort of)

On Thursday 24 May 2007 04:01:25 pm Ray Garza wrote:
> On Thursday 24 May 2007 11:29:26 am Ray Garza wrote:
> > I have some PC's that have a built in NIC w/option to boot from network.
> > I try using it but it cannot get the info from the DHCP Server. If I boot
> > from floppy it works fine.
> >
> > The built-in nic is a VIA Rhine II Fast Ethernet Adapter v2.14 and it us
> > using Intel UNDI, PXE-2.0 to boot from.
> >
> > You think I may have to upgrade the system BIOS? I'm not even sure if
> > there is an upgrade. I'll have to look. Is there anything I can do on the
> > server side to help it along?
> >
> > I've looked at the log files but didn't see anything about this pc trying
> > to connect.
> >
> > I've checked the archives and people have had success with this card but
> > no details were provided.
> >
> > Thanks,
> >
> > Ray Garza
> > Coordinator of Computer Services
> > Speer Memorial Library
> >
> > _______________________________________________
> > K12OSN mailing list
> > K12OSN redhat com
> > https://www.redhat.com/mailman/listinfo/k12osn
> > For more info see <http://www.k12os.org>
> I updated the BIOS to the MB and it still doesn't work. Errors with No DHCP
> reply so I gave up and booted from floppy. Problem solved :)
Ok looking over my original email I realized I forgot one teeny-weeny fact, I 
piggybacking on an existing network with another box (IPCop).

I have an existing network of about 200 PC's running through IPCop (static 
IP's). Out of those 200 PC's I needed to convert 16 PC's over to k12ltsp 
(using the same physical network). I've read others were doing it so I 
figured it would work too as long as I turned off DHCP services on the IPCop 

IPCop: DHCP services: OFF - network: 
K12ltsp: DHCP Services: ON - network: 192,168.1.0/24. 
Both on the same physical network.

For the most part the setup is working but here is what I have observed:
I have a few PC's that have the built-in nic as described before. The one I 
had trouble with will not boot from the NIC using the BIOS configuration. The 
other PC's will boot from the NIC via BIOS configurations. So, I'm thinking 
that it was just a single PC issue.

The rest of the PC's boot from the floppy because they have no buil-in nic and 
we don't have the bootproms installed.

Booting from the floppy I get several (about 4) "No IP found" errors then it 
kicks in and loads up. I thought that it might be from heavy network load but 
I looked at it this morning under light traffic and still got the same "NO IP 
Found" errors. It looks like I get 3-5 of those errors then it kicks in and 
boots up.

I really don't see it as a major problem right now. Even under heavy network 
load the k12 clients seem to work fine. Well, at least they are able to boot 
up and people can log on and surf the web.

I'll have to wait and see later on when the k12 pc's get more useage. Anyone 
see anything that could account for the "NO IP Found" errors? I have a 
Netgear gigabit and CISCO 3550 switch between the the k12 server and the 
PC's. I wonder if they could be causing the errors.

Oh well, sorry for the omission of some vital information. Just an oversite.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]