[K12OSN] Failed Moodle Install - Why ?

Paul Nelson pnelson.k12 at gmail.com
Sat Sep 22 06:54:37 UTC 2007

On 9/20/07, Ken Johnson <ken.tech1 at gmail.com> wrote:
> I reinstalled K12LTSP twice, followed the Moodle Howto twice, both times wit
> the same result. The setup created what it was supposed to, I run SHOW
> DATABASES and the Moodle Database shows up. Service mysql start shows ok.
> Is it a permissions issue? How should it be set?
> Whatever mistake I'm making, I'm consistent (both installs)
> I'm almost over the goal line, but I'm a few yards short.
>  On 9/20/07, Immanuel Derks <I.Derks at translucent.nl> wrote:
> >
> > >
> > >  I get an error message in red that says:
> > >
> > > "We could not connect to the database you specified. Please check your
> > > database settings."
> > >
> > > What am I doing wrong and how do I check the database settings?

Make sure you have the right database name, password and user. You can
test this by logging into mysql with your moodle user name.

mysql -u moodleusername -p  (replace moodle username with yours)

mysql wiil ask you for your password and if you get it right, you'll
be able to login. These are the same usernames and passwords you
should be entering in the web based moodle install but instead, you're
testing them in a terminal window.

Once you're in mysql you can test the database name by typing:
use moodledb;  (replace with name of your database.)

Be sure you deal with step 14 in the howto and address selinux issues.
If you are sure you have the right database info and you've set
permissions on the moodledata directory correctly then you can go
ahead an manually edit the site/default/settings.php file, but from
the error message you're getting I'm 99.999% sure that you have a typo
in your database name, username or password.

;-) Paul

More information about the K12OSN mailing list