[K12OSN] DHCP Documentation

Mel Wade mel at melwade.com
Sun Sep 23 23:27:37 UTC 2007


I'm coming back to this project.  I've tried putting the options on the
reservation and it then the client can't find the PXE/FTFP server.

With the config as below I get a ERROR! DHCPD Failed! and a Kernel Panic.

# Sample configuration file for ISCD dhcpd
#
# Don't forget to set run_dhcpd=1 in /etc/init.d/dhcpd
# once you adjusted this file and copied it to /etc/dhcpd.conf.
#
default-lease-time            21600;
max-lease-time                21600;
ddns-update-style none;
allow booting;
allow bootp;
authoritative;

option subnet-mask            255.255.252.0;
option broadcast-address      10.0.7.255;
option routers                10.0.4.1;
option domain-name-servers    10.0.4.10;
option domain-name            "ucastudent.net";
next-server                   10.0.7.254;
option root-path              "10.0.7.254:/opt/ltsp/i386";
option option-128 code 128 = string;
option option-129 code 129 = text;
option option-221 code 221 = text;

shared-network WORKSTATIONS {
 subnet 10.0.4.0 netmask 255.255.252.0 {
    range dynamic-bootp 10.0.7.10 10.0.7.150;
    use-host-decl-names       on;
    option log-servers        10.0.4.11;


    # trick from Peter Rundle <peter.rundle at au.interpath.net>
    # newer Macs
    if substring (option vendor-class-identifier, 0, 9) = "AAPLBSDPC"
    {
       filename      "yaboot";
       option vendor-class-identifier "AAPLBSDPC";
    }
    # really old iMacs
    elsif substring (option option-221, 0, 5) = "Apple"
    {
       filename      "yaboot";
       option vendor-class-identifier "AAPLBSDPC";
    }
    # Intel PXE
    elsif substring (option vendor-class-identifier, 0, 9) = "PXEClient"
    {
       # NOTE: kernels are specified in /tftpboot/lts/pxe/pxelinux.cfg/
       filename      "/lts/pxe/pxelinux.0";
    }
    # default to an i386 BOOTP image
    else
    {
       filename      "/lts/vmlinuz.ltsp";
    }

    if substring (option vendor-class-identifier, 20, 3) = "ppc" {
       option root-path "10.0.7.254:/opt/ltsp/ppc";
    } else {
       option root-path "10.0.7.254:/opt/ltsp/i386";
    }
 }
}
group    {
    use-host-decl-names       on;



    host Boys002 {
        hardware ethernet     00:C0:4F:4C:95:56;
        fixed-address         10.0.7.2;
        #option option-128     e4:45:74:68:00:00;
        #option option-129     "NIC=3c509";
   }

    host ws001 {
        hardware ethernet     00:E0:06:E8:00:84;
        fixed-address         10.0.7.1;
        filename              "/lts/vmlinuz.ltsp";
        option option-128 e4:45:74:68:00:00;
        option option-129 "NIC=3c509";
    }
    host ws002 {
        hardware ethernet     00:D0:09:30:6A:1C;
        fixed-address         10.0.7.2;
        filename              "/lts/vmlinuz.ltsp";
        option option-128 e4:45:74:68:00:00;
        option option-129 "NIC=ne";
    }
    host ws003 {
        hardware ethernet     00:D0:09:30:28:B2;
        fixed-address         10.0.7.3;
        # kernels are specified in /tftpboot/lts/boot/pxe/pxelinux.cfg/
        filename              "/lts/boot/pxe/pxelinux.0";
    }

}


On 9/7/07, "Terrell Prudé Jr." <microman at cmosnetworks.com> wrote:
>
>  50 each...you *could* do individual DHCP reservations for, say, 50 of the
> clients pointing to one LTSP server, and then have everyone else point to
> the other LTSP server.  A little high-maintenance, but it certainly does
> work.  Say your first LTSP server is 10.0.4.254 and your second one is
> 10.0.5.254.  You want to direct a specific client (MAC address
> 11-22-33-44-55-66) to 10.0.5.254.
>
> host ws001 {
>    hardware ethernet     11:22:33:44:55:66:
>    option root-path      "10.0.5.254:/opt/ltsp/i386";
>    next-server          "10.0.5.254";
>    filename              "/lts/boot/pxe/pxelinux.0";
>
> Here's another option, the one I'd be looking at over the long haul.  If
> your router and your switches all support 802.1Q VLAN trunking, then I'd
> pop each LTSP server in its own fully-routed IP subnet.  For example, using
> Cisco gear, something like this:
>
> ------------------------------------------------------
> interface FastEthernet0/1.101
>   description LTSP Server #1's subnet
>   encapsulation dot1q 101
>   ip address 10.0.8.1 255.255.255.0
>
> interface FastEthernet0/1.102
>   description LTSP Server #2's subnet
>   encapsulation dot1q 102
>   ip address 10.0.9.1 255.255.255.0
>
> ! This assumes that you propagate your routing table info via OSPF, like
> we do in my district
> router ospf 100
>   network 10.0.8.1 0.0.0.0 area 0
>   network 10.0.9.1 0.0.0.0 area 0
> ------------------------------------------------------
>
> Then, make VLAN's 101 and 102 in your switch, turn on your trunking, and
> pop whatever client ports you want for LTSP server #1 into VLAN 101, and the
> client ports for LTSP server #2 into VLAN 102.  Your LTSP servers will, of
> course, need to be put into the new subnets and VLAN's as well.  Note that
> everything's still fully routable internally throughout the school; you're
> not doing any NAT'ing here.
>
> --TP
> _______________________________
> Do you GNU!?
> Microsoft Free since 2003 <http://www.gnu.org/>--the ultimate antivirus
> protection!
>
>
> Mel Wade wrote:
>
> 1. About 50 each.
> 2. 10.0.4.0/22 - all clients
> 3.  one-NIC setup
>
> On 9/6/07, "Terrell Prudé Jr." <microman at cmosnetworks.com> <microman at cmosnetworks.com> wrote:
>
>   There are a couple of ways I can think of to do this:  do it by subnet, or
> do it by individual DHCP reservation.  The first method scales for many
> clients, but your network infrastructure really should support VLAN's.  The
> second method is very specific, but I find maintenance to be a pain if you
> have to swap NIC's.
>
>  A few more pieces of info would help:
>
>  1.)  How many clients are we talking about directing to each LTSP server?
>
>  2.)  What are the IP subnets being used on the LTSP client segment(s) of
> each LTSP server?
>
>  3.)  Are you using a two-NIC (classical) or one-NIC LTSP setup?
>
>  --TP
>
>
>
>  Mel Wade wrote:
>  I'm trying to use a third server as DHCP to direct specific clients to
> one of two other LTSP servers.
>
> On 9/6/07, "Terrell Prudé Jr." <microman at cmosnetworks.com> <microman at cmosnetworks.com> wrote:
>
>
>  Remember that K12LTSP actually does use LTSP, and furthermore, Eric makes
> *minimal* changes...and I mean *minimal*. Really--it's nearly bone-stock
> from upstream LTSP. The file locations are, with the exception of
> /etc/dhcpd.conf, identical (IIRC, he renames it something like
> /etc/dhcpd-k12ltsp.conf or something like that). By contrast, Edubuntu
> tends to move the LTSP files into quite different locations (under /usr and
> such) than upstream LTSP uses. Drives me nuts whenever I want to run
> ltspadmin.
>
>  Any time I use K12LTSP, I just use the LTSP docs, and I have yet to go
> wrong.
>
>  Anything in particular you're looking to figure out?
>
>  --TP
>
> _______________________________
>  Do you GNU!?
>  Microsoft Free since 2003--the ultimate antivirus protection!
>
>
>  Mel Wade wrote:
>  Anyone know where I can find DHCP documentation specific to K12LSTP
> client booting?
>
>
> _______________________________________________
> K12OSN mailing list
> K12OSN at redhat.comhttps://www.redhat.com/mailman/listinfo/k12osn
> For more info see <http://www.k12os.org> <http://www.k12os.org>
>
>
>
>
>
> _______________________________________________
> K12OSN mailing list
> K12OSN at redhat.comhttps://www.redhat.com/mailman/listinfo/k12osn
> For more info see <http://www.k12os.org> <http://www.k12os.org>
>
>
> _______________________________________________
> K12OSN mailing list
> K12OSN at redhat.com
> https://www.redhat.com/mailman/listinfo/k12osn
> For more info see <http://www.k12os.org>
>



-- 
Mel Wade
"The real problem is not whether machines think but whether men do." - BF
Skinner
http://www.melwade.com
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://listman.redhat.com/archives/k12osn/attachments/20070923/3900878c/attachment.htm>


More information about the K12OSN mailing list