[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [K12OSN] File permissions and ownership missing



Peter Scheie wrote:
The files in /home/*/Drives/ are pointers to local devices on the client such as USB sticks and floppy disks. Are you seeing this while logged in on a client that boots via floppy disk?

Peter

No, a terminal that PXE boots.

I did an ls -l on the file just now, and get ordinary looking permissions and ownership. But when I try to install icewm, I keep getting that same error message, but with a different username -- I looked to see if the user had processes running on the server and in each case there were processes out there, there were three users that kept ice from installing. I killed each of the user processes and now it appears to have installed icewm. I need to go on site and log in to see. (I'm home now.)

[root mail ~]# yum install icewm
Loading "installonlyn" plugin Sep 19 08:37 My_Floppy
Loading "protectbase" plugin
Setting up Install Process
Setting up repositories
Reading repository metadata in from local files:09 My_Floppy
0 packages excluded due to repository protections
Parsing package install arguments
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package icewm.i386 0:1.2.30-1.el5.rf set to be updated
---> Package icewm.x86_64 0:1.2.28-1.k12ltsp.6.0.0 set to be updated
--> Running transaction check
--> Processing Dependency: libImlib.so.1 for package: icewm
--> Restarting Dependency Resolution with new changes.py
--> Populating transaction set with selected packages. Please wait.
---> Package imlib.i386 1:1.9.13-1.el5.rf set to be updated
--> Running transaction check
--> Processing Dependency: libgdk-1.2.so.0 for package: imlib
--> Processing Dependency: libglib-1.2.so.0 for package: imlib
--> Processing Dependency: libgtk-1.2.so.0 for package: imlib
--> Processing Dependency: libgmodule-1.2.so.0 for package: imlib
--> Restarting Dependency Resolution with new changes.oppy
--> Populating transaction set with selected packages. Please wait.
---> Package gtk+.i386 1:1.2.10-56.el5 set to be updated
---> Package glib.i386 1:1.2.10-20.el5 set to be updated
--> Running transaction check96 Sep 24 08:12 My_Floppy

Dependencies Resolved
total 4
=============================================================================
Package                 Arch       Version          Repository        Size
=============================================================================
Installing:
icewm                   i386       1.2.30-1.el5.rf  rpmforge32        1.1 M
icewm x86_64 1.2.28-1.k12ltsp.6.0.0 k12ltsp 79
3 ktern not found
Installing for dependencies:
glib                    i386       1:1.2.10-20.el5  k12ltsp           137 k
gtk+                    i386       1:1.2.10-56.el5  k12ltsp           923 k
imlib i386 1:1.9.13-1.el5.rf rpmforge32 658 k

Transaction Summary
=============================================================================
Install      5 Package(s)
Update       0 Package(s)
Remove       0 Package(s)

[root mail ~]# size: 3.5 M
Is this ok [y/N]: y
Downloading Packages:
Running Transaction Test
Finished Transaction Test


Transaction Check Error:
package imlib-1.9.13-30.fc6 (which is newer than imlib-1.9.13-1.el5.rf) is alr
eady installed

Error Summary
-------------

Which brings me to another question -- I'm not sure that the script that is supposed to kill user processes (I recall that it ran when the user logs off and runs again as the user logs on) well it doesn't seem to be working. I think it is found in a k12ltsp file and you set PURGE_PROCESSES = YES or NO depending on your preference. We have a lot of processes that just get left out there. Right now, no one should be logged on yet, school has not even started, and there a many student user processes hanging around out there.

I'm not sure if I'm supposed to start another thread with this question -- but I've been meaning to ask for a while, I've just kind of been watching the issue.

Thanks

RMSELTech
RMSELTech wrote:
Has anyone ever seen a file that has no permissions and no ownership?

[root mail ~]# ls -l /home/afry/Drives
total 0
?--------- ? ? ? ?            ? /home/afry/Drives/My_Floppy

I don't know why this file has no information -- I can't delete it. If I try to remove it as a file, the error message says it is a directory. If I try to remove it as a directory, the error message says "cannot lstat the filename". And I
can't install IceWM because of it. (See the very end of the screen I
copied and pasted below.)

I really need to install Ice, because everyone is used to using IceWM as the default. I hope there are no other files like the above. It's almost as if it is corrupted
somehow.

I have pasted the screen that references this file when I try to install IceWM.

Thanks,

Rita Gibson
RMSELTech

[root mail ~]# yum install icewm
Loading "installonlyn" plugin
Loading "protectbase" plugin
Setting up Install Process
Setting up repositories
Reading repository metadata in from local files
0 packages excluded due to repository protections
Parsing package install arguments
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package icewm.i386 0:1.2.30-1.el5.rf set to be updated
---> Package icewm.x86_64 0:1.2.28-1.k12ltsp.6.0.0 set to be updated
--> Running transaction check
--> Processing Dependency: libImlib.so.1 for package: icewm
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package imlib.i386 1:1.9.13-1.el5.rf set to be updated
--> Running transaction check
--> Processing Dependency: libgdk-1.2.so.0 for package: imlib
--> Processing Dependency: libglib-1.2.so.0 for package: imlib
--> Processing Dependency: libgtk-1.2.so.0 for package: imlib
--> Processing Dependency: libgmodule-1.2.so.0 for package: imlib
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package gtk+.i386 1:1.2.10-56.el5 set to be updated
---> Package glib.i386 1:1.2.10-20.el5 set to be updated
--> Running transaction check

Dependencies Resolved

============================================================================= Package Arch Version Repository Size =============================================================================
Installing:
icewm i386 1.2.30-1.el5.rf rpmforge32 1.1 M
icewm                   x86_64     1.2.28-1.k12ltsp.6.0.0  k12ltsp
  793 k
Installing for dependencies:
glib i386 1:1.2.10-20.el5 k12ltsp 137 k gtk+ i386 1:1.2.10-56.el5 k12ltsp 923 k
imlib                   i386       1:1.9.13-1.el5.rf  rpmforge32
658 k

Transaction Summary
=============================================================================
Install      5 Package(s)
Update       0 Package(s)
Remove       0 Package(s)

Total download size: 3.5 M
Is this ok [y/N]: y
Downloading Packages:
Running Transaction Test
error: failed to stat /home/afry/Drives/My_Floppy: Permission denied
Finished Transaction Test


Transaction Check Error:
 package imlib-1.9.13-30.fc6 (which is newer than imlib-1.9.13-1.el5.rf)
is already installed

Error Summary
-------------



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]